Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here i the scenario:

  1. I am using MacbookPro as host
  2. Using VBox for creating / using VM's
  3. Using ubuntu as VM , with the installed software which needs access to my work (over VPN, of course)
  4. Have VPN Connectivity from Mac, and able to ssh to hosts @ work

I am unable to access the same hosts when logged in to the VM on my Mac.

The company network is 10.x.x. (as the case with most companies) I am using comcast at home, which defaults to a 192.168.x.x type of address

When using the same setup @ work, i am able to have access to work computers , but not when i am at home. Any clues to what i need to do to get access from within a VM?. Thanks,

share|improve this question

2 Answers 2

up vote 0 down vote accepted

VirtualBox uses some 192.168.x.y addresses by default. You'll run into conflicts if your local network uses the same subnet.

In VirtualBox, open the network preferences dialog box (File / Preferences / Network from the menu in my version). Edit the network parameters there, replacing all 192.168.x prefixes by a different prefix that doesn't conflict with your ISP or company network. There's probably room in the 10.* range or in the 192.168.* range, but you can also use a subnet of 172.16.0.0/12 (i.e. a prefix 172.a.b where 16≤a<31).

That may or may not be enough, depending on what kind of virtual network adapter you've configured. If you need more help, describe what adapters you've set up for the virtual machine (Network tab of the VM settings), and describe the network configuration on your Mac (I'm not familiar with OSX network configuration but the output from route -n would be a good start.)

share|improve this answer

If you have internet access from within the VM and you only need to access the company network from there, you could try to setup the VPN connection from within the VM. Depending on the VPN software used and your other needs this might be the easier solution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.