Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I've got a computer having DNS problems with one address only, "microsoftonline.com". Ping doesnt resolve IP but nslookup does correctly. It works from other machines. It is WinXP with no proxies

I have tried google's DNS servers with no avail. Any ideas?

The ping error is "Ping request could not find host...."

share|improve this question

marked as duplicate by DavidPostill windows May 10 at 9:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Check your hosts file, although I don't think that's likely to be the cause.

Disable the XP firewall and test.

Try net stop dnscache then net start dnscache. This seems to do something that ipconfig /flushdns doesn't, IMX.

Delete the arp cache: netsh interface ip delete arpcache

Check your routing table: route print

share|improve this answer

Try flushing your DNS cache on the machine by running this from the command line:

ipconfig /flushdns
share|improve this answer
    
Thanks, but this did not work. I've also tried repairing the network connection and restarting the computer. – Robert Wagner Dec 10 '10 at 13:23

Before going crazy resetting everything, let's try some simpler tests:

  • Can you ping google.com?
  • Can you ping google DNS: ping 8.8.4.4 ?
  • Do you have multiple IPs/Default gateways that may be conflicting ( output from: ipconfig /all)
  • Are you using both IPv6 and IPv4 on your network?
  • Can you verify the following services are running: DNS Client Network Location Awareness Remote Procedure Call (RPC) ? (open task manager, under services tab)
  • Are you running a firewall?
  • What is the output of ping -a 64.4.6.100 ? (this is the IP of microsoftonline.com)

Overall, this sounds like it could be a number of things including DNS hijacking, corrupt network somewhere, or something else strange with Windows. One post I found fixed the same issue with Windows XP by uninstalling and re-installing SP3 (weird).

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.