Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm getting this error when I try to ping 8.8.8.8 from my Virtual Machine:

PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
From 172.30.8.135: icmp_seq=1 Redirect Host(New nexthop: 172.30.8.254)
From 172.30.8.135: icmp_seq=2 Redirect Host(New nexthop: 172.30.8.254)

When I try wget http://www.google.com I get failed: connection timed out.

This is the output of route -n:

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
172.30.8.0      0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0      172.30.8.135       0.0.0.0   UG     0      100       0 eth0

This is how my network looks like: I have created br0 as a bridge over eth0 to run this VM. The host has this IP 172.30.8.135.

The host has access to internet through eth0 and this is the output of route inside the host:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
172.30.8.0      0.0.0.0         255.255.255.0   U     0      0        0 br0
0.0.0.0         172.30.8.254    0.0.0.0         UG    100    0        0 br0

Thanks in advance for any clues on this!

share|improve this question
up vote 2 down vote accepted

eth0 needs to be in promisc mode to pass traffic to the bridge

my setup is physical eth0 in promisc with no ip address, br0 with an dhcp ip and using the bridge as my "interface" for the hardware machine with a route to the gateway from dhcp, then a tap interface added to the bridge and this is used as a "bridged" interface in the virtualization product. does that help?

a tutorial on setting up virtualization with tap interfaces and reachability: http://www.blindhog.net/linux-bridging-for-gns3-lan-communications/

share|improve this answer
1  
not in the VM, on your physical eth0...you can give your br0 an IP and might be able to use that to browse from the physical machine if that's required – RobotHumans Dec 10 '10 at 15:12
1  
edited answer to be more clear i think – RobotHumans Dec 10 '10 at 15:16
1  
you don't have to set promisc on br0...ifconfig br0 dhcp && ifconfig br0 down && ifconfig br0 up should do it – RobotHumans Dec 10 '10 at 15:20
1  
what is the output of brctl show – RobotHumans Dec 10 '10 at 15:21
1  
to add a tap interface: sudo tunctl -t tap0 – RobotHumans Dec 10 '10 at 15:23

In my case helped iptables on router:

iptables -A POSTROUTING --table nat ! -o tap0 -j MASQUERADE
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .