Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently installed Microsoft Hyper-V Server 2008 and have 2 VM's running on it.

Everything works fine until some "nice looking" (could be WPF or .NET) application is executed. In that case all virtual machines hang or totally slow down.

I have read some articles about host slowing down and hanging but my host works, my VMs freeze. I have tried with default display drivers, and with NVidia drivers but no good.

Also virtual display driver have only 4MB of memory? Could this be the problem? And is there any way to increase it? It seems not from what I have found.

My hardware is:

  • Core i5
  • 8 GB DDR RAM
  • NVidia something graphics

VMs are Windows XP x64. Hardware virtualization is enabled. Hyper-V is up to date.

VM's halt when I star "Acronis true image" or "Avast" Antivirus.

share|improve this question
    
the applications that hang makes me think they are trying for raw disk access and it's making hyper-V puke –  hbdgaf Dec 10 '10 at 16:10

3 Answers 3

up vote 2 down vote accepted

There is a known issue running WPF in a virtual machine. The most common complaint is related to Visual Studio. See this article for a potential fix:

http://weblogs.asp.net/kdente/archive/2009/10/19/visual-studio-2010-beta-2-editor-performance-fix-running-on-a-virtual-machine.aspx

And to summarize in case the link ever becomes stale, you just need to set the following registry entry to '1':

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics\DisableHWAcceleration

Note that this will disable hardware acceleration, and so depending on what you are doing you might want to think it through carefully first.

share|improve this answer
1  
Surely this will not be an issue when the VM is accessed remotely, like through RDP, as is usually the case with a VM running on Hyper-V? –  paradroid Dec 10 '10 at 16:56
    
Thanx this works! I don't need HW acc because this VM's just host server apps and do backups. –  Brlja Dec 11 '10 at 18:03

It sounds like you have installed graphics drivers on the Hyper-V host, when you should be using the standard Windows drivers. I have seen the same problem in the past, with the same symptoms as you describe. I am not sure if the problem is related to Joel's answer, which could be a solution I did not know about at the time.

Remove the drivers and it should work properly again. Are you sure you were using the default Windows drivers before? You can access the XP VMs through RDP, from another machine (used as a thin client).

Virtual machines on Hyper-V (and other Type 1 hypervisors like VMware ESX/ESXi) usually run server operating systems and the hosts are headless, so the VMs are accessed remotely.

Desktop OSs are best virtualised either with Type 2 hypervisors like VirtualPC and VMware Workstation, or using VDI desktop virtualisation systems, like Citrix XenDesktop, Microsoft MED-V and VMware View (you still access the VMs using a remote client machine with these, but the local resources can be used).

share|improve this answer

In addition to Joel's answer, there's known issues with Server 2008 with Hyper-V and graphics heavy programs (being displayed on the host). MS's suggestion is to upgrade to R2, which doesn't have the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.