Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Windows 7: My time is always two hours behind the actual time.

I've changed the time, but, whenever I restart it, goes back to the incorrect time, 2 hours behind the actual time.

I'm on (UTC+02:00) Harare, Pretoria. Even if I try sync time with an Internet server, it still is incorrect by 2 hours!

How can I fix this?

share|improve this question
You changed your timezone right? From what I'm seeing it's set to UTC right now. – digitxp Dec 11 '10 at 20:58
up vote 8 down vote accepted

Click on the clock and choose "Change date and time settings..."

Click the "Internet Time" tab. Is it set up to synchronize the time with If it is, try unchecking that box, saving the settings, and rebooting to see if that fixes your problem. If it isn't checked already, try checking it and making sure it is set to

Here is an article that may explain the problem:
Windows/Ubuntu Dual Boot-Setting time in one changes time in the other

The BIOS is the base clock and keeps time when the OS is off.

He boots into Windows, and the time is out. He either fixes it by hand or via time server, and Windows helpfully 'fixes' the time on the hardware clock on the motherboard in BIOS. Then he reboots into Ubuntu, and it picks up the time from the motherboard and sets the OS to that time. It's out by 4 hours because Linux expects the hardware clock to be UTC rather than EDT. In Ubuntu he either fixes the time manually or by ntp time server, then when he shuts down Linux helpfully 'fixes' the hardware clock. And around we go...

Note you don't get this when you run one or the other virtualized - just when you dual boot.

Does that explain it better?

So it seems that for dual booting Windows and Ubuntu, both need absolutely to use a time server.

See this for Windows : Dealing With Windows Vista Time Sync Problems.

share|improve this answer
This may also be a result of dual-booting Linux or another operating system that sets the system clock to UTC. – oKtosiTe Dec 11 '10 at 21:08
I tried synchronizing with internet time but when I reboot same problem. I am dual booting with Linux. The time is correct in Ubuntu and has the correct timezone too. – darren Dec 14 '10 at 19:57
Dual-boot seems to be the cause of the problem. See my edit above. – harrymc Dec 14 '10 at 20:17
I have the same problem with dual boot and in Ubuntu everything works fine but Windows has the issue. I can set time sync but windows won't sync at startup. 1:0 for Ubuntu. – Michael May 27 '12 at 0:07
adding the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTime‌​IsUniversal=1 with datatype DWORD32 fixed the problem for me source:… – John Doe Oct 3 '12 at 18:28

Also check the Date/Time settings in the BIOS. I've found before that changing the time in Windows didn't change the BIOS clock.

share|improve this answer
I've never personally seen that issue, but it is possible some buggy BIOS might fail to set the hardware clock from the OS. – TuxRug Dec 12 '10 at 8:08
My BIOS date settings are all in order. Correct date in BIOS and in Ubuntu. – darren Dec 14 '10 at 19:58

A quick and simple answer that worked for me:

Create a file time.bat with the following contents:

%windir%\system32\sc.exe start w32time task_started

Put the bat file in your startup, then reboot. After small delay (from 30 seconds to 1 minute) system time will be corrected.

share|improve this answer

Without knowing which OS you're running, I'll assume it's either XP or W2K. Try re-registering the Time Service by typing the following commands at the command prompt (Start | Run | Type cmd, and click OK), and hitting ENTER after each...

net stop w32time 
w32tm.exe /unregister 
w32tm.exe /register 
net start w32time

Resource ->

share|improve this answer
The question title includes "Windows 7", so I would assume that the question owner is running Windows 7. – Ben N May 4 at 19:28
Why would you assume they are running Windows XP or Windows 2000, in 2010, both of those operating systems were over a decade old. I mean you had both Windows Vista and Windows 7 both on the market at that point. Besides which version of Windows the user was running, was both clear, but honestly irrelevant to any proper answer. – Ramhound May 4 at 19:59
I copied the answer as you can see. It works fir w7, too. – resw67 May 5 at 8:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.