Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to setup my rsync script to run automatically. It uses a key file for authetnication so there is no issue of missin ginput or something.

I have user a.

In user a's profile live a batch file that calls cwrsync and references the authentication key, and writes results to a file results.txt

If I run this file as user a everything works perfectly.

I tried to set this batch file as a scheduled task to be run as Administrator, and set it to start in the location of the batch file, to no avail.

The rsync, cmd and ssh executables appear to hang, never closing unless I manually end them from task manager. The results.txt file also remains empty.

I am using absolute paths for everything so that should not be an issue.

Ideas on how to troubleshoot?

share|improve this question
    
Have you tried running it under the user account that works when you tested it? –  LukeR Dec 12 '10 at 0:41
    
No, because I would need to allow that user to logon to do batch jobs, and thought it would be easier just to allow Administrator to run it. –  Jenny Dec 12 '10 at 1:15
    
you wouldn't have to do a gui login, you could use net at..... –  hbdgaf Dec 12 '10 at 3:18
    
it runs as the user....but I am still curious why it doesn't run as Administrator –  Jenny Dec 12 '10 at 16:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.