Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently switched from Firefox to Chrome, and the thing I miss most from Firefox is the "Awesome Bar" that suggests completions for what I type primarily based on page titles, and then secondarily based on domain names.

Chrome offers both matching URLs and titles, just like like Firefox, but Chrome seems to always prefer a matching domain name over a matching page title or a match to another part of the URL (besides the domain), no matter how many times I pass over the former for the latter.

In fact, Chrome also prefers to suggest a search rather than matching anything other than a domain name.

So is there any hidden preference I can change to tell Chrome that I care more about page titles than domain names?

Example: I want to go to Google Reader, so I press Control+L and begin typing "reader". The URL for google reader is http://www.google.com/reader/view/#overview-page, so the domain name is www.google.com, which does not contain the word "reader". So the first option that Chrome suggests is either another site that has "reader" as part of the domain, or a search for "reader" with the default search engine. No matter how many times I scroll down and select Google Reader, Chrome never "learns" that that's what I want.

share|improve this question
    
could you update with a specific example? It'd help me understand –  Jeff Atwood Dec 12 '10 at 7:36
1  
Excuse me for saying that, but reader.google.com would take you to Google Reader by typing "reader" (or, "r", that is). This applies to many domains, and I have become used to it when switching from firefox. –  slhck Dec 13 '10 at 14:04
    
Hmm. reader.google.com redirects to google.com/reader. I guess that's a fix for this specific case, but I would still like a general fix. –  Ryan Thompson Dec 13 '10 at 18:26
    
I recently switched to Chrome and this is what I am missing a lot. Its actually a very significant loss of productivity that I cannot go to a URL by typing a string from the title. I couldn't find any addons to do this too. –  Stewie Oct 1 '13 at 14:56

2 Answers 2

up vote 2 down vote accepted

There's no explicit way to do this in Chrome. At some point I did notice a menu in about:flags that allowed you to configure the behavior of instant (if you use instant from your omnibar) to act a little differently, but that seems to have gone away in more recent updates (I use the developer release on OS X).

share|improve this answer

Guess your best bet is to try their discussion forums or get someone to change the source code.

There is no configuration setting or extension that has access to what you are trying to do...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.