Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

due to problems with flickering und rough edges on windows, even without nvidia drivers, I try to rebuild the whole xorg by hand. I ran X -configure and got a standard xorg.conf I have to edit. I set my monitor but always get a "No screens found". How does that come?
Here is my current xorg.conf

Section "ServerLayout"
 Identifier     " Configured"
 Screen         0 "Screen0" 0 0
 InputDevice    "Mouse0" "CorePointer"
 InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
 ModulePath   "/usr/lib/xorg/modules"
 FontPath     "/usr/share/fonts/X11/misc"
 FontPath     "/usr/share/fonts/X11/cyrillic"
 FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
 FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
 FontPath     "/usr/share/fonts/X11/Type1"
 FontPath     "/usr/share/fonts/X11/100dpi"
 FontPath     "/usr/share/fonts/X11/75dpi"
 FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
 FontPath     "built-ins"

Section "Module"
 Load  "glx"
 Load  "dbe"
 Load  "record"
 Load  "dri2"
 Load  "dri"
 Load  "extmod"

Section "InputDevice"
 Identifier  "Keyboard0"
 Driver      "kbd"

Section "InputDevice"
 Identifier  "Mouse0"
 Driver      "mouse"
 Option     "Protocol" "auto"
 Option     "Device" "/dev/input/mice"
 Option     "ZAxisMapping" "4 5 6 7"

Section "Monitor"
 Identifier   "SamsungSyncMasterP2770"
 HorizSync    30-75
 VertRefresh  56-61
 Modeline "1920x1080@60" 182.28 1920 1952 2640 2672 1080 1102 1113 1135

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"            # [<bool>]
        #Option     "HWcursor"            # [<bool>]
        #Option     "NoAccel"             # [<bool>]
        #Option     "ShadowFB"            # [<bool>]
        #Option     "UseFBDev"            # [<bool>]
        #Option     "Rotate"              # [<str>]
        #Option     "VideoKey"            # <i>
        #Option     "FlatPanel"           # [<bool>]
        #Option     "FPDither"            # [<bool>]
        #Option     "CrtcNumber"          # <i>
        #Option     "FPScale"             # [<bool>]
        #Option     "FPTweak"             # <i>
        #Option     "DualHead"            # [<bool>]
 Identifier  "Card0"
 Driver      "nv"
 BusID       "PCI:1:0:0"

Section "Screen"
 Identifier "Screen0"
 Device     "Card0"
 Monitor    "SamsungSyncMasterP2770"
 DefaultDepth 24
 SubSection "Display"
  Viewport   0 0
  Depth     1
 SubSection "Display"
  Viewport   0 0
  Depth     4
 SubSection "Display"
  Viewport   0 0
  Depth     8
 SubSection "Display"
  Viewport   0 0
  Depth     15
 SubSection "Display"
  Viewport   0 0
  Depth     16
 SubSection "Display"
  Viewport   0 0
  Depth     24
  Modes  "1920x1080@60"

By the way. Why is there no xorg.conf by default? How does Ubuntu get any graphical data without it?

Here is the xorg output (It's 2 because I test the configuration with xinit -- :2)

[  7441.101] 
X.Org X Server 1.9.0
Release Date: 2010-08-20
[  7441.101] X Protocol Version 11, Revision 0
[  7441.101] Build Operating System: Linux 2.6.24-27-server x86_64 Ubuntu
[  7441.101] Current Operating System: Linux ubuntu 2.6.35-23-generic #41-Ubuntu SMP Wed Nov 24 11:55:36 UTC 2010 x86_64
[  7441.101] Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.35-23-generic root=UUID=4b44f495-fa1d-40a3-9938-8da8a4ee60d5 ro quiet splash
[  7441.101] Build Date: 16 September 2010  06:18:41PM
[  7441.101] xorg-server 2:1.9.0-0ubuntu7 (Fo    
share|improve this question
up vote 1 down vote accepted

[ 7441.884] (EE) NV: Kernel modesetting driver in use, refusing to load

Pass nomodeset on the kernel command line in the bootloader.

share|improve this answer
Thanks, that solved it :) – Bevor Dec 12 '10 at 15:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .