Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When trying to download a file found on the Microsoft downloads center that starts with, for example, i get a timeout with "Internet Explorer cannot display the webpage".

More information says:

Internet connectivity has been lost. The website is temporarily unavailable. The Domain Name Server (DNS) is not reachable. The Domain Name Server (DNS) does not have a listing for the website's domain. If this is an HTTPS (secure) address, click Tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.

Diagnose Connection problems says:

Windows cannot find the host name "" using DNS

Bear with me while i expand on the problem: It all started when i tried to download Windows XP mode for my Windows 7 machine. I went to the virtual PC site, then thru the motions of Windows Genuine Advantage which validated ok, but when it redirects to grab the file just times out with above error. (NB: i also tried with the latest Chrome and Firefox but no use due to the Genuine Advantage stuff, so i decided to stick with IE).

I am behind an ADSL2+ modem router connecting via wireless (Win 7 Pro laptop); so i hop over to the desktop connected via ethernet (Vista Business), and same result; begin to think site site is down. So i give it a break an read up on EDNS, flushing the cache, hosts file, etc...

Try again an hour later on the Win 7 machine, still no go; so i turn off the Win 7 (software) firewall, and lo and behold, i can connect and grab any files from; (...nice, so we have a Micro$0ft firewall preventing access to a Micro$0ft website, no wonder my auto-updates kept failing but that's another story).

But i still am not happy that the desktop connected via ethernet still cannot get to, even though i turned off all firewalls, defenders, anti-virus, etc. What is so special / specific about the url, any other site is ok, including

Any networking guru know what's REALLY going on, and how can i get the desktop to connect?

Ping -> Ping request could not find host Please check the name and try again.

Ping or even works gives me an IP address.

NB: On the wireless laptop ping works, i get [].

share|improve this question

migrated from Dec 12 '10 at 23:07

This question came from our site for system and network administrators.

up vote 4 down vote accepted

There is a "feature" of Windows Firewall that actually treats the address "" as special, without this being documented anywhere (or at least i could not easily find any mention thru Google searches).

There is also a bug in Vista that gives inconsistent information. Recall in my original question, i thought the firewall was turned off. Refer to my attached image. In "Windows Security Center" we have big writing in the red band that shows Firewall Off (#1)... but upon clicking Windows Firewall (#2), the resulting window shows that the Firewall is actually on! (#3).

So the answer is turn the firewall off and it will ping, etc. Case closed!

alt text

share|improve this answer
(+1, and not just to let you post the images, but also thanks for reporting back!) – Arjan Dec 19 '10 at 13:14
Another reason Not to use Vista! – Moab Dec 19 '10 at 14:47
An issue on Win7 too. – Victor Sergienko Jan 8 '13 at 11:32

What DNS server are you using? Run this from the command line:

ipconfig /all

and take a look at the DNS servers section. If it's your ADSL modem, try changing it to something else - here's a sample list of public DNS servers that you can try:

Choose some DNS server from the above list and do the following from the command prompt:

nslookup <IP>

where <IP> is the IP of the DNS server you chose. Do this with your current DNS server and with some of the others from the list. If some of the other ones work, then it might be an issue with the DNS server.

Also, take a look at this article for more information - this is a complete step-by-step guide for Google public DNS:

share|improve this answer
Your answer is good information to know, but the root cause is really the firewall being on. See my answer below. – joedotnot Dec 19 '10 at 13:11
@joedotnot Ah, classic... Glad you solved your poblem! – Dec 19 '10 at 18:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .