Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently upgraded my system from 6GB of RAM to 12GB. Once I installed the new RAM, Windows 7 shows in my System Information that I have "12.0 GB installed (7.99 GB usable)". Although less common, the past few days I've also seen the system info jump down to "3.99 GB usable", but it seems to jump back up to 7.99 after a few reboots.

System Information Screenshot

I have an EVGA X58 motherboard, which maxes out at 24GB of RAM, so I know I'm not reaching my motherboard's limits. All 6 RAM chips are exactly identical. The only thing different about the 6 chips is 3 are new and 3 have been in the system for about 18 months. They're all G.SKILL DDR3 1600 (PC3 12800) triple channel chips.

I'm running Windows 7 Ultimate 64-bit edition with the latest BIOS firmware and driver updates.

Is my new RAM defective, or is it normal to need to manually configure RAM timing in the BIOS in order to recognize the additional RAM?

The fact that my computer can boot and Windows acknowledges its existence makes me think it may not be defective.

share|improve this question

4 Answers 4

up vote 13 down vote accepted

Check (and double check) that they are inserted fully.

I've come across this exact problem when the modules have been insufficiently inserted.

share|improve this answer
I took out all of the new chips and inserted them again. This seemed to fix it! I would have never guessed that RAM can be inserted deeply enough to be recognized but not enough to be usable. Thank you! –  Dan Herbert Dec 13 '10 at 2:26

Defective memory doesn't always cause Windows to fail to boot. It might be a good idea to try running memtest86 or memtest86+ (available from http://www.memtest.org/ or http://www.memtest86.com/).

share|improve this answer
This happened to me, returned the RAM and got a different brand: now no problem. –  Richard Dec 13 '10 at 9:08

According to Microsoft, you could try :

  1. Change maximum memory option. Run msconfig, choose Boot tab, click on advanced options. ensure the Maximum memory checkbox were cleared.
  2. Update system BIOS
  3. Enable memory remapping in BIOS
  4. Change AGP aperture size in BIOS
  5. Check for bad memory modules
  6. Check memory arrangement into slots
  7. Check whether memory standoff cards are used

See http://support.microsoft.com/kb/978610.

share|improve this answer

When I’m looking to upgrade a PC for myself or somebody else I always go to Crucial Memory website that I trust very much and has proven to be a great help through the years.

This is the link, http://www.crucial.com/systemscanner/ I run it on the PC that I’m rebuilding and it gives me information on my current memory Specs. and some guaranteed compatible upgrades. It’s a great way to find out what’s in the machine quickly.

When I run it this is what it reports:

Memory Type: DDR3 PC3-10600, DDR3 PC3-12800, DDR3 (non-ECC) Maximum Memory: 16GB Currently Installed Memory: 8GB Total Memory Slots: 4

Although it states that max the max memory it can run is 16GB I found other info regarding that subject. Here’s what my research discovered. The maximum amount of memory that your system can use is actually limited in two ways — not only is there a maximum amount of memory that your computer motherboard can accept, there is also a maximum amount of memory that your operating system (OS) can accept.

Windows 8 (32 bit)

Windows 8 Enterprise: 4 GB

Windows 8 Professional: 4 GB

Windows 8 Home: 4 GB

Windows 7 (32 bit)

Ultimate: 4 GB

Enterprise: 4 GB

Business: 4 GB

Home Premium: 4 GB

Home Basic: 4 GB

Starter: 2 GB

Windows 8 (64 bit)

Enterprise: 512 GB

Professional: 512 GB

Home: 128 GB

Windows 7 (64 bit)

Windows 7 Ultimate: 192 GB

Windows 7 Enterprise: 192 GB

Windows 7 Professional: 192 GB

Windows 7 Home Premium: 16 GB

Windows 7 Home Basic: 8 GB

Windows 7 Starter: N/A

share|improve this answer
They already said that their motherboard supports up to 24GB and that they are using Windows Ultimate 64-bit. –  Synetech Jan 6 '14 at 15:06
Synetech, must be nice to have time on your hands to post challenging comments that are open ended, why don't you be useful and ask the original poster did they check the CMOS to see if the mainboard Bios recognized the memory? or if they ever solved their issue, be a real contributor and stop trolling! –  Pete Jan 6 '14 at 16:13
You posted an answer to a two-year-old question, stating that their system is limited by the motherboard and/or edition of Windows even though they clearly accounted for both of those factors. Moreover, they already accepted an answer two years ago and explained that it was because their RAM was not properly seated and re-seating them fixed it. You obviously did not bother to read the actual question or take a look at the other answers. How exactly is it “trolling” to point out how completely completely wrong, late, and useless your post is? –  Synetech Jan 6 '14 at 16:22
Well my shallow minded friend, lets look at this way. Since I'm not myopic like you, I'm always forward thinking. Lets say somebody enters a query into a search engine and they find this post because they have the same issue with their memory not being recognized, wow they might find my info useful...Oh but you didn't think of that did you...so troll on and thank you for being the message board police!, don't go away mad just away... –  Pete Jan 7 '14 at 15:25
Too bad your information is not unique, and thus still useless. Yes, I’ll take my years of experience and knowledge and helping people away and let you take over with your useless, repetitive, redundant copy-pasted information… once every few days when you stop by just spout off for no reason. –  Synetech Jan 7 '14 at 15:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.