Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to connect my PC to my TV via HDMI. It works fine under Ubuntu, but it's not working under Windows 7 (32-bit).

The video card is an ATI 4670, the TV is a Philips 74xx series and the monitor is a Dell 19" model that connects to the PC via VGA.

The TV receives signal and shows picture while the PC is booting (i.e. during the BIOS self-check and the Windows 7 logo). However, the TV says there is no signal after the Windows login screen comes up.

I have installed the latest CCC and ATI video card driver. Does anyone have any ideas?

share|improve this question
    
is the pc a laptop? –  KronoS Dec 13 '10 at 13:58
    
@KronoS, it's a pc –  Kane Dec 13 '10 at 15:26
    
for fun have you tried connecting just the TV to the computer, to see if it will work on its own? –  Xantec Dec 14 '10 at 16:13
    
@Xantec, thanks. I'll try this. But both monitor and tv could show the pc's picture if using Ubuntu. –  Kane Dec 16 '10 at 7:58
    
Do you have your desktop extended or cloned to the tv? If not it will just shut off the TV when Windows boots. –  Kyle Feb 11 '11 at 21:58
show 7 more comments

3 Answers 3

Press the (Windows key + P) to change from the 4 different ways to use multiple monitors/projectors; it could be that you are using it in computer only mode. Since you did mention that Ubuntu shows up.

share|improve this answer
add comment

Try taking a look in the resolution settings etc and ensure that output to the additional screen is enabled. Display->Settings. Both screens should be visible in the both, but one may not be set up for use.

If you can not see both, try using the "detect" button.

share|improve this answer
    
it's weird. The CCC or windows 7 could detect the tv as the second monitor when the power of tv is off. It won't detect the tv when turning on the tv or switching to the signal source to hdmi. –  Kane Dec 13 '10 at 15:29
    
Have you tried switching through the different HDMI signal sources? –  Danny Staple Dec 13 '10 at 17:50
    
When connecting to the PC is it via a DVI connector? –  Danny Staple Dec 13 '10 at 17:52
    
Tried switching different HDMI signal source, but it doesn't work. The video card supports VGA, DVI and HDMI output. Currently HDMI connects with tv, VGA connects with 19' Dell monitor. I don't have DVI cable, so no chance to try connect pc monitor via DVI. –  Kane Dec 14 '10 at 12:49
add comment
up vote 0 down vote accepted

The problem probably is caused by the manufacturer of video card.

I bought a new vide card(ATI 5450 series), which works well.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.