Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The Synaptics touchpad in my new laptop doesn't scroll at all in a number of applications, including Steam and Zune.

I've narrowed the problem down to Synaptics not sending mouse wheel messages, but rather manipulating scroll bars.

I'm only looking into one-finger side-of-touchpad scrolling, not two-finger scrolling.

Is there a way to make it send wheel messages so that it is compatible with all applications?

Configuration:

  • Windows 7 64-bit
  • Dell XPS 14
  • Latest Synaptics driver (have tried both from Synaptics and Dell)

My Synaptics options window looks like this and I've tried moving all the options to no avail:

enter image description here

share|improve this question
    
Your question is missing a crucial piece of information: your operating system. –  Gilles Dec 13 '10 at 23:01
    
Could you specify your model a bit more precisely? –  Tobias Plutat Jan 25 '11 at 16:45
    
It's this one: dell.com/us/p/xps-14/pd –  Juliana Peña Jan 25 '11 at 17:36

4 Answers 4

up vote 9 down vote accepted

After almost two years, I FINALLY found the solution!!

As explained in this article, it's as simple as editing the registry and adding a DWORD at HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh with name UseScrollCursor and value 0 and restarting SynTPEnh.exe.

This fixed the problem in Steam and Zune flawlessly, with both edge scrolling and two-finger scrolling.

share|improve this answer

Are you certain your laptop is a synaptics touchpad?

Do you know if your touchpad may be from ALPS? Dell often uses ALPS touchpads on some laptops as well

share|improve this answer
    
The laptop comes with Synaptics drivers. My older Inspirion laptop had an ALPS touchpad, but the new XPS line uses Synaptics –  Juliana Peña Dec 13 '10 at 16:28

This thread suggests going to Control Panel, then Mouse, then Device Settings until you see something like this:

screenshot of Properties for Synaptics TouchPad

Then, two things to try:

  • Untick/uncheck Enable virtual scrolling
  • Click the [+] to the left of Virtual Scrolling and change from "Scroll selected item" to "Scroll item under pointer"

If those options don't appear, can you post a screenshot of your settings? Maybe there is an option to use a different scrolling mode or to exclude certain applications.


Otherwise, there is a program called TwoFingerScroll that sounds like it might help.

share|improve this answer
    
Thanks for the answer, but my options window looks nothing like that (here's a screenshot: i.imgur.com/YqVVY.png ) I don't have the "Virtual scrolling" option, just "Scrolling". Turning it off disables scrolling completely. I don't want two-finger scroll, just right edge one-finger scolling. –  Juliana Peña Jan 25 '11 at 2:32
    
I tried the TwoFingerScroll program and it works! It send regular wheel messages and scrolls in all applications. If only there was a way to make one-finger side-of-touchpad scrolling work like that... –  Juliana Peña Jan 25 '11 at 15:19
    
I'll give you the bounty because it's the only solution that sort-of worked. The TwoFingerScroll program scrolls in all apps, but it's not really the one-finger edge scrolling I was looking for. –  Juliana Peña Jan 30 '11 at 22:18
    
Thanks so much. Wish I could have been more help. –  Mikel Jan 31 '11 at 1:35
    
Release notes for version 6.7.3.4: "Due to this change, "Scrolling selection" option on the touch pad Properties panel was removed." download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/6hgx31ww.txt -- does that explain the difference between Mikel's screenshot and Juliana's? –  Dan Jan 31 '11 at 15:56

There is a suggestion in this thread :

The problem imho is not caused by the driver, but it's the SynTPEnh.exe, which is responsible for the scrolling and other features (kill the process in TaskManager, and two finger scrolling won't work an more in any application).

If you manage to run this tool with elevated privileges, two finger scrolling should work even for applications that were started as administrator.

One way to do this is to create a task in the task scheduler, that will start SynTPEnh.exe with highest privileges at logon.

Question: Did you install drivers from Toshiba's website? Or did you let Windows 7 automatically install the drivers?

share|improve this answer
    
I don't want to disable scrolling, I just want it to work in all applications (it doesn't work in Steam, Zune or TortoiseHG, for example). I killed that process and it just disables it completely. Also, I want regular side-of-touchpad one-finger scrolling, not two-finger scrolling. My driver is the lastest one from Synaptic's site. –  Juliana Peña Jan 25 '11 at 15:13
    
Did you try to restart it with "Run administrator" ? –  harrymc Jan 25 '11 at 15:30
    
The apps don't scroll not because they're run by administrator, they don't scroll because they have custom scrollbars that the Synaptics software can't manipulate. Sending regular mouse-wheel windows messages instead of manipulating scrollbars would fix this. –  Juliana Peña Jan 25 '11 at 17:38
    
There is no "manipulation" of scrollbars in Windows. Devices such as the touchpad send scroll messages directly to the active window. However, some products in search of sexier scrollbars simply paint their own scrollbars and handle themselves all mouse clicks. Since as far as Windows is concerned these windows have no scrollbars, the touchpad messages will never even be sent. If that's your case, then there is no possible solution. –  harrymc Jan 25 '11 at 20:05
    
But Alps touchpads and normal mice scroll perfectly in these types of Windows... –  Juliana Peña Jan 27 '11 at 15:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.