Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

[Running Win7 Ultimate 64 bit]

My new HP Pavilion Elite HPE-450t has been plagued by BSDO crashes since I got it about 5 weeks ago. The crashes are somewhat rare, sometimes not occurring for 3 or 4 days. I have spent a lot of time trying to isolate the device that could be at fault, but I have seen crashes with only the keyboard and mouse plugged in (as USB devices), and I tried two sets of keyboard/mouse, so I'm running out of ideas. :(

The WhoCrashed tool gave this info about my latest BSOD:

crash dump file: C:\Windows\Minidump\121310-11887-01.dmp
This was probably caused by the following module: usbport.sys (USBPORT+0x2DE4E) 
Bugcheck code: 0xFE (0x5, 0xFFFFFA8008F571A0, 0x80863B34, 0xFFFFFA80092F2510)
Error: BUGCODE_USB_DRIVER
file path: C:\Windows\system32\drivers\usbport.sys
product: Microsoft® Windows® Operating System
company: Microsoft Corporation
description: USB 1.1 & 2.0 Port Driver
Bug check description: This indicates that an error has occurred in a Universal Serial Bus (USB) driver.
The crash took place in a standard Microsoft module. Your system configuration may be incorrect. Possibly this problem is caused by another driver on your system which cannot be identified at this time. 

I looked at http://msdn.microsoft.com/en-us/library/ff560407(VS.85).aspx, and for Parameter1 = 0x5, it says "A hardware failure has occurred due to a bad physical address found in a hardware data structure. This is not due to a driver bug".

Should I conclude that it's a hardware issue in the machine itself, rather than a bad USB driver or USB device?

Here is the MiniDump, in case someone can get more info out of it: http://ewt52q.blu.livefilestore.com/y1peS4Ce8nSK1SXghzMDoxDWXlaEu-EKCJsv25y8y5DXXIUzZ9U0_tYgFJXd939fykwa0zRmx98IW0PYG18GioqKAuARYjtspSA/121310-11887-01.dmp?download&psid=2

share|improve this question
1  
Try updating your chipset driver –  Moab Dec 13 '10 at 20:26
1  
Since it's so new, have you tried contacting HP support about getting it fixed/replaced under warranty? –  nhinkle Dec 14 '10 at 0:28
    
@nhinkle: I will do that if it comes down to it, but I'm hoping to find a fix that will save me this hassle. –  David Ebbo Dec 14 '10 at 7:12
    
@moab: I have never done this, so I wouldn't know where to start. But I'll look into it. –  David Ebbo Dec 14 '10 at 7:32
    
Use this utility (CPU_Z) to see what chipset you have, post it and I will try to find the latest driver for you....cpuid.com/softwares/cpu-z.html –  Moab Dec 14 '10 at 18:50

1 Answer 1

up vote 2 down vote accepted

I have the same problem with the same machine and Windows 7 and Windows 7 SP1; I've forwarded my dumps to the USB team at Microsoft.

Because HP has declined to provide the required BIOS update to address the issue, a workaround script that should prevent the problem is here: http://ericlawrence.com/dl/FixSeries5USB.zip

share|improve this answer
    
Marking as answer as Eric connected me with the right Microsoft folks who found that it is (apparently) caused by some new Intel USB feature. Turning it off in the kernel debugger fixes it, though I'm still waiting for a more permanent fix. –  David Ebbo Jan 30 '11 at 2:09
    
It appears that the blue screens in Windows 7 usbehci.sys on my HP Pavilion Elite HPE450t are caused by a bug in the Intel 5 Series chipset used by the motherboard. Alas, no fix until HP releases a BIOS update. 33. Intel® 5 Series Chipset and Intel® 3400 Series Chipset Not Responding to Cx Request when USB Async Advance Door Bell is Set intel.com/assets/pdf/specupdate/322170.pdf –  EricLaw Jun 15 '11 at 13:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.