Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have a DNS server at work that maps <developername>.zende.sk to each developer's computer so we can see one another's work. These paths are not routable from the WAN. On OSX and on virtualized Windows (which I presume uses the underlying OSX's DNS lookups), I can go to http://me.zende.sk, but this fails on a Windows XP machine.

When I run nslookup me.zende.sk from the Windows machine, I get

Server:  someresolver.com
Address:  1.2.3.4

Non-authoritative answer:
Name:    something.zende.sk
Address:  9.8.7.6
Aliases:  me.zende.sk.zende.sk

I tried going to http://me.zende.sk.zende.sk and it worked like a charm. Why?

I've gone into my networking settings in Windows and fiddled with the "Append primary and connection specific DNS suffxes," "Append parent suffixes of the primary DNS suffix," and "Append these DNS suffixes (in order)" settings, all to no avail.

share|improve this question
add comment

2 Answers

I think your DNS server may be misconfigured - could some entries in the zonefile be lacking the trailing . that is normally required?

share|improve this answer
add comment

Go to your network connections, right click on your network adapter and select "Properties". Look for some kind of IP v4 option (it shows up as Internet Protocol Version 4 (TCP/IPv4) on my Windows 7 system, but will likely be a little different on XP. Double-click this and then click the Advanced button the window that opens. Now click on the "DNS" tab.

Here there are several options that control how your domain is appended as a DNS suffix. I don't know what is set there or what is supposed to be set there - it depends on how your dhcp server is configured. But whatever you see there now is wrong, and playing with the settings a bit should give you something that works.

And Apple got lucky on this one - Apple's Bonjour/mDNSResponsder service is a steaming pile.

share|improve this answer
    
This is the screen that has the options that I mentioned at the end of my post, but none of them seems to do the trick. –  James A. Rosen Dec 13 '10 at 19:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.