Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently running OpenSuSE 11.3. I'm afraid as newer versions are released they will demand more of my old PC (Dell Optiplex GX270).

Also, I've heard of issues with newer Linux distributions having issues with older Intel hardware (just hearsay, not personal experience). However, patches for specific OpenSuSE releases have a limited window of time.

So,

  • Am I much more at risk to security issues if I keep a version of Linux past its patch date?
  • Is it possible to keep a specific Linux release but still be able to receive security essential updates based on my repository selection?

Thanks

share|improve this question
    
"If it ain't broke, don't fix it". –  harrymc Dec 14 '10 at 8:21
add comment

2 Answers 2

up vote 3 down vote accepted

The short answer to your question is yes, running an old version is a potential security risk.

Why? Because many distros tend to end security patches at some point in the lifecycle. Also, even if the old version is supported for critical security patches, you still end up with software packages that are hopelessly out of date. On my Intrepid Ibix Ubuntu laptop that I couldn't upgrade due to old hardware I started noticing all sorts of little glitches start to enter in. Firefox even complained that I was using this or that old library and scolded me for not upgrading. I'm sure other packages of lesser quality have similar problems but just aren't telling me. I kept on with the laptop until a few months ago, though, because it just didn't seem like a big risk--nowhere near as bad as family members using Windows who end up getting completely infested with a trojan cocktail just for visiting crochet sites.

The longer answer is that if you know your stuff and work with a specific distro and know your packages/libraries, etc. it's possible to keep everything patched up. It seems to me that distros like Debian and Slackware cater more to those of us who want to run an old machine yet have a stable, secure system.

share|improve this answer
add comment

There shouldn't be any need to do this. The Linux kernel really isn't that demanding. What might be is your desktop environment. Try Xfce or another lightweight desktop environment instead of the one you're running (KDE, if you haven't changed it).

As for Linux having issues with older Intel hardware, I haven't heard of anything like that, but either way, I don't think your hardware is old enough. That machine, though not modern by any means, should be able to run Linux just fine.

To answer your question though, yes, not being up to date on your operating system is always a security risk, though that risk is arguably negligible since you are on a Linux-based OS and not many threats currently target Linux. The other problem is there could potentially be some unfixed bugs in the version you're using (which will be fixed in a future release), though this is unlikely to be a problem.

share|improve this answer
    
Neither Xfce nor GNOME are window managers; they are full desktop environments - a WM, a desktop, a file manager, a panel/program menu, and user programs. (I think SuSE comes with KDE by default. GNOME isn't that bad on resources, however.) –  grawity Dec 14 '10 at 10:23
    
@grawity: Thanks for the clarification, I didn't know the terminology you Linux people use. :) And new versions of Gnome can be pretty slow on older hardware in my experience--there's a lot of eye candy there. –  Sasha Chedygov Dec 14 '10 at 21:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.