Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently installed Windows 7 on a computer and network connection indicator does not change after connecting to network.

I do not know correct terms, so I posted pictures. When there is a WiFi network available, I get following icon in the lower right part of the taskbar:
wireless networks available

After I connect to a network, I should get following image,

connected to wireless network

but instead I get this:

what I get (image same as image 1)

It doesn't change even when I disable WiFi card and connect to a wired network or when there is no Internet connection available.

How do I fix this?

share|improve this question

1 Answer 1

After you are connected, can you access the internet?

I found this link that may help you. Comment back to let me know how it went. I will continue to research this for a little bit.

I also found this here.

· Does this happen when computer returns from sleep or hibernation mode?

· What is the anti-virus installed on your computer?

  1. Verify relevant service

i. Click "Start", go to run, type "services.msc" (without quotation marks) in the open box and press Enter.

ii. Click Continue button to verify the administrator permission.

iii. Right click the "Network Location Awareness" service and choose Properties.

iv. On General tab click Start.

v. Choose Automatic next to Startup type.

vi. Click OK.

  1. Even scan and repair the WMI Repository Database on the computer. To do this, follow these steps:

i. Click Start, type cmd in the Start Search box, and then press ENTER.

ii. At the command prompt, type the following commands. Pressing ENTER after each command line:

winmgmt /verifyrepository

winmgmt /salvagerepository

iii. Restart the computer.

Here is another possible fix to this solution:

You may also want to check for updates drivers for your wireless card. Here is another idea: disable IPv6 in TCP/IP settings:

Search -> View Network Connections Identify the WiFi adapter/NIC Double-click on it and go to Properties Uncheck Internet Protocol Version 6 (IPv6)

This could be:

An old driver problem A problem with IPv6 A registry problem which may require clearing the networks.

Under Network and Sharing Center you should only have one active network when under WiFi.

share|improve this answer
    
Yes, as far as I can see, network connection works fine. I can access Internet and other computers in LAN and other computers can access me and everything looks good, except the image. –  AndrejaKo Dec 14 '10 at 13:32
    
I'll try it out and report. –  AndrejaKo Dec 14 '10 at 13:55
    
I tried everything those links suggested, and it didn't help. –  AndrejaKo Dec 14 '10 at 16:42
    
Ooo, I found another link that is perfect. I am trying to decipher the solution. windows7forums.com/windows-7-support/… –  David Dec 14 '10 at 16:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.