Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to change the default interface language (menus, buttons, shortcuts etc) of MS Office 2010. I find it very annoying that they have made up ad.hoc. Swedish names for loads of things making searching for something you have a problem with a nightmare.

Also, the Swedish version have non-industry-standard-shortcut-keys, for instance:

  • Lets say you want to make the text bold. Ctrl + B? You would have guessed wrong: Ctrl + F
  • You want to find a word in your text? Ctrl + F? Oh no thats right, that made the text bold...

Ghaa! This drives me crazy. Anyway, moving on to my problem.

This problem could be fixed in two ways, right?

  1. Change the global language settings in "Language Settings"
  2. Change the shortcut keys.

Ok, fine. This is a screenshot of the "Language Settings": alt text

opening up Word...:

alt text

It's still in Swedish! And my custom shortcuts are gone (see the mouse hover over the bold button) Ghaa.

EDIT: Actually - the only language installed might actually be Swedish. Pressing the text on the bottom of the first screenshot, I'm transfered to a "Microsoft Language Pack" page, the English language pack is... $30. Well. No. I wont pay that to get the default language. Stupid.

share|improve this question
    
I came here with the exact same problem (except for Dutch instead of Swedish). After two and a half years, has anybody found a solution yet? Microsoft offers LIPs (Language Interface Packs) which are free downloads (as opposed to their full language packs) but naturally, they don't have a LIP for English. –  Mr Lister Apr 14 '13 at 11:02

2 Answers 2

Have you tried to delete the swedish language, thus leaving the english only, this should force MS to use english, also Bloodphilia makes an excellent point, you need to enable both parts, but either way I'd erase the other languages you don't need, for memory.

share|improve this answer
    
I had similar problem, deleting other languages and letting only the language you want worked for me. –  Johnny May 9 '11 at 12:11

Yeah the funny thing is that the language options screen comes up in English, not Swedish. Normally you don't get the option to run the UI (and consequently, shortcuts) in English when you have a foreign language version. Not sure what the drill is in Sweden since English is virtually a native language there... interesting what Johny said. Anyway, see How to change office shortcuts?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.