Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been racking my brain (and the internet) for way too long on this issue, and I could really use some help. I've tried just about everything I can think of to get this issue resolved, and I've run out of ideas on what to do.

I am trying to install Open Office 3.2.0 on a Red Hat server that doesn't have a GUI, but I'm having relentless dependency issues. My currently installation (I've tried with 3.2.1 first, but the only headless RPM I could find was for 3.2.0)

The files that I am using for my installation are the following: - OOo_3.2.0_Linux_x86-64_install-rpm-wJRE_en-US.tar.gz (182MB) from's download site: files/stable/3.2.0/ - from

From here, I unzip the tar to get the folder: OOO320_m12_native_packed-1_en-US.9483/RPMS. If I try "rpm -i *.rpm" at this point, I get dependency issues because of the gnome-integration and kde-integration files, so I mv them to another folder.

When I run the rpm -i command again, everything runs as expected.

Now I move to the location of the headless rpm I mentioned above, and attempt to get that file. When that runs, I get the following output:

warning: desktop-integration/ Header V3 RSA/SHA256 signature: NOKEY, key ID e8e40fde error: Failed dependencies: is needed by is needed by is needed by is needed by is needed by is needed by is needed by is needed by is needed by is needed by = 1:3.2.0-12.33.fc13 is needed by = 1:3.2.0-12.33.fc13 is needed by 
    rpmlib(FileDigests) <= 4.6.0-1 is needed by 
    rpmlib(PayloadIsXz) <= 5.2-1 is needed by 

Unfortunately, using YUM is out of the question, as openoffice is not being listed in its repository.

Personally, I'm very green at using Redhat, though I do have a couple months of using Linux under my belt.

share|improve this question
this is just dependency troubleshooting...install the appropriate libraries and openoffice will work – RobotHumans Dec 14 '10 at 17:06
up vote 0 down vote accepted

The package you found was built for a much newer system, and cannot even be unpacked properly with the currently installed rpm — the rpmlib(PayloadIsXz) and rpmlib(FileDigests) dependency errors are due to the version of rpm which does not support the newer package format. Apparently the switch to xz compression was done in Fedora 12, so you don't have any chance to install Fedora packages newer than *.fc11 on this system.

share|improve this answer
Interesting... Let me take a look into an older version of Open Office. I checked the version of RedHat and found that this machine is using RHEL 5.5, which seems to be equivalent to Fedora 6 (please correct me if I'm wrong), so this seems like it might be the answer. I'll let you know how that works out. – VOIDHand Dec 15 '10 at 15:50
We ended up going a different direction with a simple pdf printer. Thanks for the input to the both of you! – VOIDHand Dec 21 '10 at 21:07

Normally you'd use yum to install the packages, even if you're not installing them from a repository. You just need to make sure that there's a "/" in there somewhere, e.g. yum install ./*.rpm.

However, you have a bigger problem. rpmlib(*) dependencies are, for the most part, unfulfillable on a given system unless they're already in place, since they represent base rpmlib functionality. You will need to grab the appropriate SRPM from Fedora and rebuild, probably using mock.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .