Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I change Windows 7 file permissions using the command prompt?

I want to change permissions in program files, but cacls is not working for me.

share|improve this question
    
similar problem has been answered here: serverfault.com/a/533848/69330 –  Jörg Aug 26 '13 at 14:57

4 Answers 4

cacls is depcriated in Windows 7. You need to use ICACLS instead of cacls.

ICACLS "filename" /grant "Users":F

This command is granting the privileges.

share|improve this answer

To change permissions, use an administrator account on that machine to run CACLS. If you have UAC enabled, you may have to elevate the command prompt first by right-clicking on it and choosing "Run as Administrator".

You can use cacls as follows:

CACLS files /e /p {USERNAME}:{PERMISSION}

Where,

* /p : Set new permission
* /e : Edit permission and kept old permission as it is i.e. edit ACL instead of replacing it.
* {USERNAME} : Name of user
* {PERMISSION} : Permission can be:
      o R - Read
      o W - Write
      o C - Change (write)
      o F - Full control

For example, to grant your user account full (F) control to files, you would use the following command (typed in an elevated Windows command prompt):

CACLS files /e /p %USERNAME%:f

Read complete help by typing following command:

cacls /?
share|improve this answer

you need to run cacls with administrator right in order to change permission in program files...

share|improve this answer
    
how to run cacls as administrator using command itself? –  sam Dec 15 '10 at 9:20

If, for any reason, files have become disassociated with the administrator account in Windows 7, using ICACLS will NOT restore them.

You are forced to manually click EACH file, one at a time, and select Properties > Security tab > Advanced button > Permissions tab > Continue button.

If enabled, approve UAC prompt for Permissions Editor for Files and Folders and Uncheck Include inheritible permissions from thsi object's parent. Click the Remove button when prompted, then re-enable Include inheritible permissions, click OK.

This will restore your accesss to the file.

How can this be accomplished against an entire folder or set of files? Using ICACLS *.* /RESET does not work; it ends in error "Access is denied" for the files in question.

share|improve this answer
2  
This is not a forum, so if you have a new question, please ask a new question using the big button above. –  slhck Jun 10 '12 at 7:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.