Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have some files/directories on an external hard drive connected using USB to my Windows XP laptop. I am trying to delete those files but every time I try, I get an error "Cannot delete ....: Access Denied. Make sure disk is not full or write protected and that the file is not currently in use".

I checked that the directory is not is use. However, the permissions are set to read-only. Even if I remove the "read-only" checkbox, in Properties->Attributes, it automatically comes back again. How do I fix this? Is it a virus that is automatically changing it back to read-only?

regards,

JP

share|improve this question
add comment

1 Answer

Your problem isn't that the folder is read-only. This blog post can point you to why.

Chances are the permissions on the folders themselves would need reset. The easiest way to fix that is to right-click on the drive in Explorer, go to Properties -> Security Tab -> Advanced -> Check "Replace permission entries on all child objects with entries shown here that apply to child objects" -> Click Ok.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.