Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In my corporate environment, I'm required to run a Windows machine that acquires a VNC session on a machine in the server farm. My windows machine is dual head with different resolution monitors ( 1600x1080 on left and 1920x1200 on right). If I create a VNC session that spans the monitors, then maximizing a window in the VNC session causes it to stretch across both my monitors.

Instead, I want a "maximize" event to behave like it does on my windows machine -- I only want to maximize to the display that the window is on.

How can I define what, what I'll call, "maximize regions"? Regions in the VNC graphical plane where when I click "maximize", the window only expands to the region it currently ( and mostly) resides in.

Can I do this in gnome, X, xrandr, or some other magical interface?

share|improve this question

2 Answers 2

I'm assuming xrandr and xdpyinfo show your display as being a single screen with a size that's like both displays added together, e.g. 3520x1200.

So what you want to do is try to split the screen back into two logical desktops somehow.

The easiest way I know to do that is to use what's called a "tiling window manager". xmonad and dwm are two examples.

Another option is to use a window manager that allows only vertical maximizing, such as Openbox, Blackbox, or Sawfish. Often they have shortcuts to do this, e.g. middle click on the maximize button in the title bar.

Yet another option is to use something like Devilspie, that sets window properties based on rules, e.g. place Firefox at 0x0 with size 1600x1080, etc.

share|improve this answer

You need to turn off Xinerama. This is done in the /etc/xorg.conf file. This may also kill your ability to do dual head though. If you're running on NVIDIA setup a proper xorg.conf with the 'nvidia-settings' program and you won't need Xinerama.

share|improve this answer
    
This is VNC. Are you sure nvidia settings have something to do with this? –  Ross Rogers Dec 15 '10 at 19:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.