Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having a problem with putting my snow leopard imac to sleep - when i do ctrl+cmd+eject (or whatever the shortcut is to put it to sleep) it goes sleep, it wakes up 20 secs later.

After it wakes up, i do the shortcut to put it to sleep again and it stays down.

It's been doing this for the last month or so. I'm suspecting it may be skype - i've started using that lately (although it may not be, too).

Any suggestions? Thanks

-edit-

One thing i noticed this morning, is that when it woke itself up, it flashed a message on the screen saying the mouse had been disconnnected (i have a magic mouse). The battery is newly replaced in the mouse however.

share|improve this question
    
Do you have peripherals connected? A magic trackpad under a shifting stack of paper? Or do you maybe use FaceTime on your Mac? –  Daniel Beck Dec 16 '10 at 2:03
    
Only have the mouse and keyboard, no other peripherals. –  Chris Dec 16 '10 at 2:52
    
It is not unusual for a Bluetooth mouse to disable while the computer is asleep. You will then see the "Disconnected" when the computer wakes, and then you have to wiggle the mouse to wake it and it will be "Connected". I made an edit to my answer to remove this as a factor. –  Ken Dec 16 '10 at 23:42
    
Might be worth a try disabling wake for network access: superuser.com/questions/179131/… –  Chris Dec 17 '10 at 2:18
    
I tried disabling wake for network access, that didn't work. –  Chris Dec 19 '10 at 0:13
add comment

1 Answer

Reboot, and try putting it to sleep at the login screen. If that works, try going to sleep again immediately after you login. If that doesn't work, check the Login Items for your Account in System Preferences. After that, it would be something you've run.

You can run /Applications/Utilities/Console and search All Messages for "wake" and "sleep"

Edit: to remove Bluetooth as a factor, open Bluetooth in System Preferences, open the Advanced sheet, and uncheck "Allow Bluetooth devices to wake this computer".

share|improve this answer
    
I'll definitely try those suggestions. –  Chris Dec 16 '10 at 0:41
    
In the console, how do i search the messages as you suggest? –  Chris Dec 16 '10 at 0:42
    
Not "the console", but the Console app. I made an edit, but the simple way to find it is to use Spotlight. Search is in the top-right, as usual. –  Ken Dec 16 '10 at 1:05
    
Well, there's nothing in the console. I guess i'll kill my apps one at a time until it goes away. –  Chris Dec 16 '10 at 11:51
    
If i uncheck that setting, would that mean my (wireless) keyboard would then lose the ability to wake the computer? –  Chris Dec 17 '10 at 0:58
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.