Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sometimes, my Windows XP does not load correctly. It shows the login screen, and when I click my username, it load the desktop background, but the Explorer does not show up. So, I cannot see the icons on the desktop, the start menu, etc.

If I press Ctrl+Alt+Del to show Task Manager, I can run programs (like media player or browser) from File-->New Task (Run...).

Also, in the Task Manager, I see Explorer.exe running. I tried to kill and re-run it, but nothing happens.

I used Sysinternals Process Explorer to see if there were any odd process or odd behavior, but nothing was fishy.

After several restarts, the system finally worked as expected. But this is not permanent: Sometimes, when I restart the system, it works just as described above (Explorer does not show up). But sometimes it works normally.

I used Kaspersky to search for viruses, but nothing showed up.

I think the info presented above is not enough to pinpoint the problem. Yet you might be able to tell me about a tool or something, which I can use to give you more info, or even solve the problem.

PS: I can easily use the Safe Mode. It does not seem to suffer from this problem. Hence, I suspect there's some process (service) for which Explorer is waiting, but that process runs into trouble (say a race ondition, or an infinite loop) and so Explorer stalls as well.

share|improve this question
    
Run a chkdsk on the hard drive –  Moab Dec 16 '10 at 0:50
    
@Moab: Thanks, but chkdsk didn't solve the issue. I ran "chkdsk /F C:" and it required a restart (since C: is locked). After a restart, Windows ran the scheduled chkdsk. It didn't find any problems. chkdsk then restarted the system. Finally, the logon screen appeared and I logged in, but the Explorer stalled again. –  Sadeq Dousti Dec 16 '10 at 1:22
    
I would run a memory tester...memtest.org .... Download the prebuilt ISO, burn it to CD as an Image (not data), boot from that CD and run the memory test for a couple of hours or overnight to stress test the memory. –  Moab Dec 16 '10 at 1:39
    
@Moab: Thanks again. It's hard to believe that memory modules got corrupted, but nothing's impossible, so I'll give it a try. Meanwhile, any other suggestions are welcome. I'm specially interested in a tool that profiles the system startup and notices odd behavior of services. –  Sadeq Dousti Dec 16 '10 at 2:27
1  
See this article on enabling boot logging...msigeek.com/6231/… –  Moab Dec 16 '10 at 14:59
show 3 more comments

1 Answer

A possibility - for which I can offer no evidence - is that you have a virus that is hanging on start up. Virus scanners don't detect all viruses. You could try some other of the free scanners to see if they detect something. If they don't, then they are simple enough to remove afterwards.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.