Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I drag or resize a window near any edge or corner of either monitor, Windows wants to maximize or resize the window for me in several different ways:

  • dragging a window near a corner offers resize to full-screen
  • dragging directly to the corner offers half-screen maximize
  • resizing to top or bottom edges offers a vertical maximize (one long strip from top to bottom)

Actually, now that I think about it the 3rd one isn't so bad, its just the full and half-screen maximize features that drives me mad.

Is there a registry hack to disable these settings, preferably independently?

share|improve this question
    
This drives me nuts. It's a great feature for looking at two windows side by side easily and I don't know why it took until Aero for MS to introduce it, but I want it to work only when dragging a window's titlebar, not when dragging window edges. It should also be an option in the window management (i.e. top left corner) menu. –  John Ferguson Mar 14 '14 at 9:29

2 Answers 2

up vote 27 down vote accepted

This Windows 7 feature is called Aero Snap. Here's the easy way to disable it completely:

  1. Go to Control Panel.

  2. Click on Ease of Access link or Ease of Access Center icon.

  3. Select Change how your mouse works or Make the mouse easier to use option.

  4. Tick the check box for Prevent Windows from being automatically arranged when moved to the edge of the screen with the mouse under “Make it easier to manage windows” section.

And here's the roundabout way via the registry:

  1. Run Registry Editor (RegEdit).

  2. Navigate to the following registry key:

    HKEY_CURRENT_USER\Control Panel\Desktop
    
  3. In the right-pane, double click (or right click and select Modify) on WindowArrangementActive, and set its REG_SZ value to 0 to disable ; 1 to enable.

  4. Close Registry Editor.

  5. Log off and log on again, or restart computer for the change to take effect.

Hope this helps! I haven't found any way to retain functionality for a single edge - it's either all on or all off.

share|improve this answer
3  
The first method disables Win+R & Win+L key functionality for me. Is there a way to just disable auto maximize when Window touches the top edge of screen while preserving the snap to left/right functionality. –  buffer Jun 29 '13 at 6:20
    
@buffer: you may be interested in my script at link –  Codism Jun 22 at 20:25

I'll add an answer here because a similar behavior can also happen due to a certain third party application called Dell Display Manager. This software can cause a similar behavior to Aero Snap, or at least when searching for solutions, this post comes quite high in Google, so because I struggled to fix this, I'm going to post the solution for future victims of this program :D.

The problem is solved by opening the application and disabling "easy arrange" by selecting a no-layout icon (as in the second picture below).

This is how the behavior caused by Dell Display Manager looks like (when you drag a restored window around the screen).

enter image description here

and this is how you fix it:

Dell Display Manager

I got this application together with my Dell monitor. Like most software made in China it is quite buggy (actually it's among the best such programs I've used, much less buggy & horrible than others). Usually, hardware manufacturers have terrible software but this one is quite useful due to auto-setting of brightness level based on running application.

The problem can be fixed if you open Dell Display Manager. You will see that it has some example window layouts in the lower part of the window. You can also access these if you go to "Configure" (that is available when it's in "Auto mode"). There, you have a tab called "Easy Arrange" and that's where the problem is. In "easy arrange", the Dell Display Manager tracks window movements and attempts to reorganize them based on various available layouts. Depending on the layout you selected, it will draw yellow boxes on the screen. I had one where my screen was split in two: one thin vertical yellow box on the right and a larger one on the left. When the window was in one of the boxes, the border became red.

I posted this on the Microsoft Forum where somebody actually had the exact issue I was having:

http://answers.microsoft.com/en-us/windows/forum/windowsrt8_1-desktop/disable-automatic-split-screen-when-moving-apps/7420e90e-ecdf-45da-a776-50521448d626?rtAction=1426355414495

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.