Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been doing some Google searches and come up short.

Output is the following

$ easy_install yolk
'import site' failed; use -v for traceback
Traceback (most recent call last):
File "/usr/bin/easy_install-2.6", line 10, in <module>
  load_entry_point('setuptools==0.6c9', 'console_scripts', 'easy_install')()
File "/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/pkg_resources.py", line 271, in load_entry_point
  return get_distribution(dist).load_entry_point(group, name)
File "/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/pkg_resources.py", line 2174, in load_entry_point
  return ep.load()
File "/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/pkg_resources.py", line 1907, in load
  entry = __import__(self.module_name, globals(),globals(), ['__name__'])
File "/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/setuptools/__init__.py", line 2, in <module>
  from setuptools.extension import Extension, Library
File "/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/setuptools/extension.py", line 2, in <module>
  from dist import _get_unpatched
File "/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/setuptools/dist.py", line 5, in <module>
  from setuptools.command.install import install
File "/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/setuptools/command/install.py", line 2, in <module>
  from distutils.command.install import install as _install
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/command/install.py", line 21, in <module>
  from site import USER_BASE
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site.py", line 516, in <module>
    main()
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site.py", line 499, in main
known_paths = addsitepackages(known_paths)
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site.py", line 291, in addsitepackages
  addsitedir(sitedir, known_paths)
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site.py", line 185, in addsitedir
  addpackage(sitedir, name, known_paths)
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site.py", line 155, in addpackage
  exec line
File "<string>", line 1, in <module>
AttributeError: 'module' object has no attribute '__plen'

Any ideas?

share|improve this question

1 Answer 1

It seems you have a busted easy-install.pth. The easiest fix would be to nuke it out of existence; in a terminal you run:

sudo rm /Library/Python/2.6/site-packages/easy-install.pth

However this will have the side effect that you must reinstall the packages you've installed with easy_install.

By the way, try pip - it doesn't suck as much.

pip is a tool for installing and managing Python packages, such as those found in the Python Package Index.

pip is a replacement for easy_install. It mostly uses the same techniques for finding packages, so packages that are easy_installable should be pip-installable as well. This means that you can use pip install SomePackage instead of easy_install SomePackage.

share|improve this answer
    
cheers, thanks alot! :) –  Sigh M Dec 17 '10 at 1:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.