Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a desktop machine with an ATI VGA/DVI AGP card driving two monitors. Everything is peachy until I connect to this machine via a remote desktop session. After a remote desktop session, I return to my desk to find one monitor completely off, and the second monitor shows a black screen and will display the cursor if I move my mouse over there.

I'm usually successful in logging in blindly, but it is getting more difficult now that my company has instituted a disclaimer screen after you login, that requires you to press OK before continuing.

I'm not sure if it is related to the problem but Windows 7 defaulted to think the monitor on the DVI card (display #1) was the primary, and the VGA (display #2) the secondary. I changed that default and set display #2 as the primary. It seems as if Windows is still outputting the primary screen to display #2 (i.e. the VGA monitor), however it isn't powering on the VGA port.

It is probably a bug given I'm running the RC of Windows 7, but just looking for ideas on workarounds.

share|improve this question
    
Darn all I can find are posts that tell you how to change the background... –  Ivo Flipse Aug 13 '09 at 13:50
    
I'm also seeing the same issue with Win 7 RC. I also notice that all apps that I used over remote appears on screen2 after I log in. My assumption is that when you use remote desktop it uses the screen that most closely match the resolution given when you connect and thus moving everything to your secondary screen. –  Pär Björklund Aug 13 '09 at 13:51

4 Answers 4

up vote 2 down vote accepted

I don't think that this is specific to Win7, I have had similar multi-monitor issues with XP, Vista and Win7, and with both ATI and NVIDIA graphics cards.

The problem is that it does matter which monitor is labelled #1. Switching the 'Primary' monitor setting in the display settings works fine most of the time, but as you can see it causes problems in some situations.

Windows assigns the first monitor that it detects as display #1 - but this can't be changed in Windows display settings (changing the primary monitor does not change which display is labelled #1).

The solution then, is to get Windows to re-detect your displays in the correct order:

  1. Unplug your second monitor
  2. Uninstall the display drivers
  3. Restart
  4. Re-install the display drivers
  5. Restart and log into Windows
  6. Now plug your second monitor back in

This will ensure that your main monitor is detected as display #1

PS. I think that the ATI display driver control panel may actually have an option to let you change which monitor is labelled #1.

share|improve this answer
    
I upvoted this answer because I believe it is on the right track. However, following your directions did not fix the problem. Perhaps there's more I need to "clear" on step #2 to get this to work. I'm using a card with both DVI and VGA ports, so perhaps they are locked in a certain order as well? –  Ken Pespisa Aug 25 '09 at 15:55
    
The magic phrase to Google is "monitor identity" (that filters out most of the discussions about simply swapping the primary monitor). Unfortunately the consensus seems to be that there is no way apart from swapping/unplugging cables and re-decting until it works. I am now sure that both ATI and NVIDIA drivers both used to be able swap monitor identities. That feature has certainly been removed from the more recent drivers. (Perhaps it doesn't work in Vista/7?) –  subman Aug 25 '09 at 18:12
    
I stand corrected. I thought your instructions didn't have any effect, but I came in this morning after having used Remote Desktop last night, and the correct monitor turned on! Phew! I was getting tired of blindly logging in :) –  Ken Pespisa Sep 1 '09 at 13:30
    
Odd, I've always had my Monitor #2 as my primary and I haven't run into any problems. . . –  surfasb Aug 5 '11 at 23:26

I have frequent problems in primary/secondary monitor switching. I don't use remote desktop, but I undock and hot redock my laptop frequently. I haven't found a fix per se, but I did find that unplugging the supposed "primary" monitor would often cause the non-primary monitor to take action and display the right screen.

If one monitor truly won't load, then I don't know... Does the same monitor (and connection to computer) work in single monitor mode in the same scenario?

share|improve this answer

Set your monitors to clone mode. Unfortunately, this results in duplicating the video all the time :)

Try setting your other monitor as the primary in Windows. Failing that, switch up your BIOS detection setting.

share|improve this answer
    
What is the bios detection setting? –  Ken Pespisa Aug 15 '09 at 13:43
    
Somewhere in the BIOS there's an option to detect PCI/PCI-X/AGP/Onboard video first. When you first boot, within a few seconds, the computer tells you to press a button to get in. –  tsilb Aug 15 '09 at 18:26

It feels almost like more of a driver issue to me, do you know what card you have and whether it's going to get Win7 drivers from ATI? Many of the older AGP cards are not going to get Win7 drivers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.