Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 7 Ultimate, and when I do ipconfig /all in the command prompt I get, in addition to the Ethernet adapter Local Area Connection that I expected, something called Tunnel adapter Teredo Tunneling Pseudo-Interface. What is this? What can I use it for?

share|improve this question
add comment

3 Answers

up vote 20 down vote accepted

Teredo is a protocol that allows computers behind a NAT firewall (most home computers are) and without a native IPv6 connection to access remote IPv6 resuorces. The idea is that home users can start accessing IPv6 web services before their local connection supports the protocol, making the transition from IPv4 easier.

share|improve this answer
add comment

Found this after a quick google.

According to wikipedia, http://en.wikipedia.org/wiki/IPv6, it's some sort of a new TCP/IP protocol .


To make a long story short, it means you have IPv6 installed as part of your networking components. Check the following;

Go to Control Panel and double click Network Connections. Right click on the icon for your Local Area Connection and select Properties from the menu.

On the General page of the properties sheet there's a box which should contain an entry for Microsoft TCP/IP version 6.

I won't bore you with the details but the bottom line is that most people have no need at this time for IPv6. That said, it won't lead to problems if you leave it installed on your computer. That said, uninstalling IPv6 won't cause you to lose your internet connection. The entry you see for Internet Protocol (TCP/IP) is the important one.

If you're curious about IPv6, here's a web site with more information.

IPv6 for Microsoft Windows: Frequently Asked Questions http://www.microsoft.com/technet/network/ipv6/ipv6faq.mspx

share|improve this answer
add comment

If you'd like to disable this in Windows 7:

  1. Make sure you are an administrator or have access to an administrator account.
  2. Right click on Computer, choose "Manage."
  3. In the left-hand menu, under System Tools, left-click on "Device Manager."
  4. Now, right-click on "Device Manager."
  5. Hover over "View >" and click "Show Hidden Devices" in the menu that pops up.
  6. In the center pane, look for a group called "Network Adapters" and expand it by double-clicking on it.
  7. You will see a list of all of your adapters, including the one in disabled.

I haven't had any issues after disabling these yet. If I become concerned about accessing resources on an IPv6 network, I will re-enable these.

share|improve this answer
    
And what is the advantage of disabling this? You'll need to troubleshoot it later... –  Tom Wijsman Jan 29 '11 at 0:53
2  
Why would I want to disable it? –  Svish Jan 31 '11 at 9:20
    
@Svish to troubleshoot a networking issue. this moment i'm having an issue where machine A runs win7. I can't ping machine A from machine B. When I ping machine A from itself I get back an IPv6 address. I don't know why. temporarily disabling IPv6 (if I can) might simplify things a bit to narrow down to the problem. though funnily enough i'm still getting an IPv6 address back when pinging myself - just ::1:: rather than a longer one. –  barlop May 13 at 20:21
    
I was getting a long ipv6 address when I pinged myself from myself- ping compname. now i'm getting ::1::. I'd like an IPv4 address when pinging. Interestingly I can't ping from another machine. but my point re your answer is this might not totally disable it. I tried unchecking IPv6 in lan propeties too, though didn't see that do anything. your method did a little more though still pinging gives ::1:: on this machine –  barlop May 13 at 20:23
    
@barlop fwiw the win7 fw was disabling ping by default. that was the issue.. nevertheless stlil worth pointing out i was getting the ipv6 respnose when pinging myself locally despite ipv6 being allegedly disabled. –  barlop May 13 at 20:37
add comment

protected by nhinkle Apr 19 '11 at 2:44

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.