Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After rebooting my Macbook Pro, when I click Skype to open it, it says "This file has been downloaded from the Internet, are you sure you want to open it?"

alt text

It doesn't give me the option "this session" and "forever" as other applications did.

How can I tell Skype that it is ALWAYS ok to execute on my Macbook?

share|improve this question
1  
I don't remember ever seeing the dialog with "this session" and "forever". If you select Open once, it removed the attribute and you're done for the future (until you download a new version of the application). –  Daniel Beck Dec 17 '10 at 8:04
    
@Daniel Beck, I think it is likely to be related to whether the application has been properly signed... –  bubu Dec 17 '10 at 9:39
    
Are you running Skype from the disk image (dmg) ? –  0xced Dec 17 '10 at 14:15
add comment

1 Answer

up vote 4 down vote accepted

choice 1. disable all this sort of prompt

defaults write com.apple.LaunchServices LSQuarantine -bool NO

choice 2. disable this sort of prompt for 1 application

xattr -d -r com.apple.quarantine /Path/to/application/
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.