Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have purchased a Draytek Vigor 2920n router and now I ran into a VPN client settings problem, in which I would like to ask someone to help me.

My story: I subscribed to a VPN service a couple of weeks ago. I have been using it from my desktop computer with L2TP/IPsec connection; it works perfectly. But it would be useful for me, if I was able to connect other equipments as well to this VPN link aside my PC, I have a TV and Bluray-player, which have internet browsing capabilities as well.

So, I decided to purchase a “2920n” router, which has VPN client capabilities. With this router (and with the IP address, username, password and pre-shared key, I got from the VPN service provider) I could establish the L2TP/IPsec VPN connection to the VPN server.

My problem is, that beside the router’s “VPN” green LED is switched on, I am unable to link or route the traffic of LAN (my PC, TV and PS3) through the VPN tunnel, for the purpose of reaching the internet through the VPN service provider’s server, instead of reaching it directly. If I set the checkbox labeled “Change default route to this VPN tunnel”, the internet connection is lost completely, and my Windows7 OS reports that the “DNS server does not answer”. From this point, I do not know what have I forgotten to set up and where? I use only WAN1 (WAN2 is disabled), and use DHCP on WAN and LAN side as well.

I would like to ask someone to help me setting up this router to link the LAN-side (or only one LAN connection, i.e. LAN1) to the internet through the VPN tunnel.

The interesting part of my VPN tunnel problem is, that if I go to (i.e.) www.google.com site, before I establish the VPN connection with the router, and leave the browser open, and then I switch on the VPN client, I can use the google-search and get search-results through the VPN tunnel (the packets go through the VPN tunnel, it is seen on the router’s VPN tunnel packet counter as well).

But if I click on one of the link of the google.com site, and my PC sends out a DNS request, it cannot go through the tunnel again and results in a “DNS server does not answer” message. It seems that it has a problem with only the DNS request-packets. If I check the traffic with Wireshark, I see the outgoing DNS-request packets, but there is no answer to it.

This is my router: »www.draytek.com/user/PdInfoDetail.php?Id=115

Thank you for advance!

share|improve this question
    
is udp getting dropped by the vpn provider? you could try using a dnssec server (TCP and SSL instead of udp) –  hbdgaf Dec 17 '10 at 9:19
    
It sounds like DNS settings are the issue. You are probably using DNS servers that are restricted to your ISP's customers, and coming though the VPN you don't look like a customer. –  David Schwartz Mar 11 '12 at 16:02

1 Answer 1

What DNS settings are you using on your clients?

Try specifying the 2920 as the DNS server on your clients so that it acts as a DNS proxy, but then also check which DNS servers the 2920 is picking up and using.

If the 2920 has an interface similar to the 2820/2930s with which I am familar then you can set your own DNS server settings on the router and then tick a button to force their use (use manual DNS settings) - try setting the router to use Google (8.8.4.4 and 8.8.8.8) or OpenDNS (208.67.220.220 and 208.67.222.222). Your VPN link provider may also have preferred DNS settings so do check.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.