Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently switched to a new laptop running Windows 7. For some reason I am constantly getting certificate errors when hitting sites where I really shouldn't be getting them - twitter, picasa, google analytics (but gmail works), my bank, etc.

This is happening in all browsers. This is happening in all networks (at work and at home). This is definitely an issue with my laptop or operating system. I know the usual cause is my date being set incorrectly, but it's definitely correct.

The error I am getting in Chrome is the following

The site's security certificate is not trusted!

You attempted to reach www.site.com, but the server presented a certificate issued by an entity that is not trusted by your computer's operating system. This may mean that the server has generated its own security credentials, which Google Chrome cannot rely on for identity information, or an attacker may be trying to intercept your communications. You should not proceed, especially if you have never seen this warning before for this site.

I have tried manually accepting the certificate, but it doesn't work - I still get the same error every time.

I checked this answer - Endless Security Certificate Errors - and used that advice (reset my Internet settings), but it didn't make any difference.

share|improve this question
add comment

4 Answers 4

up vote 3 down vote accepted

Your problem might be that your new computer is missing some root certification authority (CA) certificates.

See this article: Windows root certificate program members

where you can manually download and install all third-party root certificates that are distributed via the Windows Root Certificate Program.

share|improve this answer
    
Thanks - I had about 15 root certificates where I should have had about 100. –  Jaco Pretorius Dec 17 '10 at 10:17
add comment

Be sure that the date of your computer is accurate.

A dead CMOS battery might reset the date to the early 2000 every time the computer boots which will prevent a certificate from being valid, since they have an expiration date and a validity date.

Localhost certificate with a valid date from 11/2/2012 to 11/1/2017

share|improve this answer
    
Thank you! This is exactly the problem I had. –  axk Jan 25 at 13:05
    
CMOS battery had died. I replaced it, got the security errors described in the question. Updating the system time, closing all browsers, and trying again fixed it. Thanks! –  Judah Himango May 1 at 2:02
add comment

I'm using Windows 8 and Explorer 10

The solution may be as simple as looking on your control panel for the newest programs that were loaded most recently on the same day and deleting them. About four days ago my browser started posting an invalid certificate on every web page. Yes even the good owes like Google, Yahoo, AOL... etc. No matter what web page I went to, the invalid certificate warned me of the web page. Windows defender missed them in the scan. When you look at this issuer of the certificate it says DO_NOT_TRUST_FiddlerRoot. There we about four or five programs that were installed on the same day. Once of them was named Browser Safeguard and it was installed on the same day as the other four programs so I deleted it too then rebooted. I also went to:

Internet Explorer/Internet Options/Connections/Local Area Network (LAN) Settings and uncheck the Proxy Server box.

No more problems with invalid certificates.

share|improve this answer
add comment

Had the same problem on Windows 7 where any secure website would give an invalid certificate error message in any browser for Chrome, IE, and Firefox.

As a solution, I found the Browser Safeguard in my programs and deleted. No problems after that.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.