Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

yesterday I let the update manager install a whole bunch of updates for my 10.04 install on my MSI Notebook ER710. My wireless was just working peachy until then (with the madwifi drivers), but after the update, no more... I checked the madwifi, tried a new make, but nothing worked.

So, after reading somewhere that 10.10 had less issues with wireless I decided to upgrade to 10.10 in the hope that that would solve my problem.

Well, partly it did, as in, according to my system I've got a wireless again and this morning even, it was able to see wireless networks! Unfortunately I couldn't connect to mine, although the key was correct. At some point I lost the ability to see wireless networks again. I tried wicd too, but no luck their either. It recognizes my card but can't see any networks.

Any help would be appreciated, here is all the info: (PS I posted a similar question here once, but then I'd just forgotten the on/off switch of the wireless, no such luck this time, it's on)

Machine Brand and Model (PC/Laptop): MSI ER710


02:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)


eth0      Link encap:Ethernet  HWaddr 00:21:85:4d:82:78  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::221:85ff:fe4d:8278/64 Scope:Link
          RX packets:7113 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5009 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7608720 (7.6 MB)  TX bytes:796091 (796.0 KB)
          Interrupt:43 Base address:0x6000 

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:52 errors:0 dropped:0 overruns:0 frame:0
          TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:5198 (5.1 KB)  TX bytes:5198 (5.1 KB)

wlan0     Link encap:Ethernet  HWaddr 00:15:af:cf:e2:ca  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off


Module                  Size  Used by
rfcomm                 33811  4 
binfmt_misc             6599  1 
sco                     7998  2 
bnep                    9542  2 
l2cap                  37008  16 rfcomm,bnep
parport_pc             26058  0 
ppdev                   5556  0 
snd_hda_codec_atihdmi     2411  1 
joydev                  8735  0 
arc4                    1165  2 
snd_hda_codec_realtek   217971  1 
snd_hda_intel          22107  2 
snd_hda_codec          87552  3 snd_hda_codec_atihdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               5040  1 snd_hda_codec
radeon                827837  3 
snd_pcm                71475  2 snd_hda_intel,snd_hda_codec
snd_seq_midi            4588  0 
snd_rawmidi            17783  1 snd_seq_midi
snd_seq_midi_event      6047  1 snd_seq_midi
ttm                    56633  1 radeon
snd_seq                47174  2 snd_seq_midi,snd_seq_midi_event
pcmcia                 35973  0 
ath5k                 130083  0 
drm_kms_helper         30168  1 radeon
share|improve this question

1 Answer 1

up vote 0 down vote accepted

You need to blacklist the ath5k and activate the madwifi drivers.

share|improve this answer
try something like this ( – bubu Dec 17 '10 at 11:11
I already tried the madwifi route again, but no luck, but this link has some extra information. I'll give it another shot and let you know. Cheers! – Peter Dec 17 '10 at 11:21
And there we are! I followed those much more detailed instructions then the ones I had and it work! Wohoo! Thanks a million Bubu! – Peter Dec 17 '10 at 12:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.