Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I check if KMS is enabled in my kernel? I've compiled mine with KMS radeon modeset defaulting to 1, but I still suspect that it is not enabled.

EDIT:

aatiis@aiur ~ $ dmesg | grep drm
[drm] Initialized drm 1.1.0 20060810
[drm] Initialized radeon 1.33.0 20080528 for 0000:01:05.0 on minor 0
[drm] Setting GART location based on new memory map
[drm] Loading RS780 CP Microcode
[drm] Resetting GPU
[drm] writeback test succeeded in 1 usecs

EDIT 2:

aatiis@aiur ~ $ glxinfo | grep render  
IRQ's not enabled, falling back to busy waits: 2 0
direct rendering: Yes
OpenGL renderer string: Mesa DRI R600 (RS780 9612) 20090101  TCL

aatiis@aiur ~ $ sudo grep -i kms /var/log/Xorg.0.log
[    57.201] (II) [KMS] drm report modesetting isn't supported.
share|improve this question

2 Answers 2

up vote 2 down vote accepted

An easy test is this. Start an X session, then switch to a virtual terminal. If there's a slight delay, like the screen darkening for a second or so, KMS is NOT enabled. If it's near instant, it's almost certainly working.

share|improve this answer
2  
is there any way to do it without X? I'm trying to install wayland –  bobbaluba Oct 6 '12 at 4:24

Kernel modesetting for radeon driver is supported after kernel version 2.6.31. If you have the driver with the version of later, you will be able to see a line that says "radeon kernel modesetting enabled." in dmesg log. Please check if dmesg contains any string with "modesetting."

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.