Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Last night my wife's laptop running OpenSUSE appears to have had some sort of failure such that on start-up it gives a whole bunch of errors and ends up prompting for a root password to start up with read-only access to a shell.

In this read-only mode I was able to view that all of the important files appear to still be there so I want to back them up before doing anything.

I attached an external USB drive and it comes up with a message:

usb 4-3: new high speed USB device using ehci_hcd and address 3
usb 4-3: new device found, idVendor=152d, idProduct=2338
sub 4-3: new device strings: Mfr=1, Product=2, SerialNumber=5
[...etc....]
scsi3 : SCSU emulation for USB Mass Storage devices
scsi 3:0:0:0: Direct-Access WDS WD25 WD-[...more hard drive info...etc.]
[...etc...]
sd 3:0:0:0: [sdb] Assuming drive cache: write through
 sdb: [mac] sdb1 sdb2 sdb3 sdb4
sd 3:0:0:0: [sdb] Attached SCSI disk
sd 3:0:0:0: Attached scsi generic sg2 type 0

So I assume all that means is that it found the drive.

Now, I want to mount it to be able to copy files to it.

Two questions?

  1. How do I find it i /dev/
  2. Even if I find it, how do I mount it when I only have read-only access?

Thanks for any help here.

share|improve this question
    
OK - I just ran mount -n -o remount,rw / and now appear to be in read-write mode. Still could use help mounting the external drive though. –  chaimp Dec 17 '10 at 16:09
    
Can we get the output if fdisk -l? But if I have to gues I'd say mkdir /mnt/tmp && mount /dev/sdb1 /mnt/tmp. –  Bobby Dec 17 '10 at 16:10

1 Answer 1

up vote 1 down vote accepted

You can even remount the file system by force remount - just remember you need to fsck the system. if the system mount it as read only there must be something wrong with the filesystem.

mount -n -o remount /

for the usb stick, usually it is emulated as scsi, you can use

fdisk -l

to list all the connected drives at the moment. for mounting e.g. a ntfs drive, on /dev/sdb1, try:

mount -t ntfs-3g /dev/sdb1 /mnt

substitute vfat if you are using fat16/32.

share|improve this answer
    
Alright. fdisk -l gives me: "Disk /dev/dd: 250.0 GB .... Disk /dev/sdc doesn't contain a valid partition table" I tried mounting with the above command and that did not work. I have tried several things and at one point, I did manage to get it to mount read-only, but since I'm trying to write to it that was not what I'm trying to do. What do you think the next best option is? I could try a regular usb stick. Do you think it will make a difference? –  chaimp Dec 17 '10 at 16:31
    
i think you want to post the whole fdisk output in your original question. if you want to copy things out i think you can try to get the harddisk out and use explore2fs/mount it in other box. –  bubu Dec 17 '10 at 16:34
    
Ah - I got it read-only again using "mount /dev/sdc3 /mnt/" (by process of elimination). It gives me "hfs: write access to a jounaled filesystem is not supported, use the force option at your own risk, mounting read-only." (I'm guessing jounaled is "journaled") So this probably means better to go with a USB stick that I can easily reformat. There's stuff on this external drive that I don't want to lose. –  chaimp Dec 17 '10 at 16:37
    
you are correct –  bubu Dec 17 '10 at 16:41
    
worked with the usb stick - thanks for telling me about fdisk -l. I have everything backed up (using cp -a and also made a .tar.gz just in case...). Now ready to wipe the drive. Do you have any recommendations about fixing the drive or will a clean install of Ubuntu where I let it format the drive fix things through reformating? –  chaimp Dec 17 '10 at 19:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.