Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Slackware on /dev/sda6 and lilo at MBR, after that I installed Debian Squeeze beta2 on /dev/sda7 and grub at first section of /dev/sda7, I added at /etc/lilo.conf record for debian ( I was doing this with other versions of Debian and it worked ), but when I try to enter to Debain I got error message

First sector of /dev/sda7 doesn't have a valid boot signature

Can anybody help ?


@Gilles fdisk -l

Disk /dev/sda: 250.1 GB, 250059350016 bytes 255 heads, 63 sectors/track, 30401 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x00e20a72

Device Boot Start End Blocks Id System /dev/sda1
1 13 102400 7 HPFS/NTFS Partition 1 does not end on cylinder boundary. /dev/sda2
13 5100 40861696 7 HPFS/NTFS /dev/sda3 5101
30401 203222379+ 5 Extended /dev/sda5 5101 14826 78124063+ 7 HPFS/NTFS /dev/sda6
14827 22699 63232000 83 Linux /dev/sda7 * 22699
30009 58716160 83 Linux /dev/sda8 30009 30401 3147776 82 Linux swap

share|improve this question
1  
It looks like you didn't actually install Grub there. How exactly did you install Grub? What version? What is the output of fdisk -l, and of </dev/sda7 head -c 512 | hd? – Gilles Dec 18 '10 at 0:01
    
I install during instalation, there is options for that. – Damir Dec 18 '10 at 7:19

You must log in to answer this question.

Browse other questions tagged .