Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My pc won't boot into BIOS anymore ... hard disk, fans etc are all spinning, there just isn't any display, no bleeps, and there's also no reading processes heard from the hard drives.

I know the pc battery was nearly empty (or completely empty?), the pc didn't remember current date anymore. That was so since a year though ...

Could the battery be preventing the pc booting into BIOS ? That seems illogical, yet I have read comments on the internet stating that could be the problem ?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I've seen firsthand some laptops' inability to switch into the BIOS menu due to unhooked battery, unhooked AC, or weak CMOS battery charge, but it was extremely rare.

But because there's no POST beep from your machine, I'd try reseating the RAM modules and power supply connection (if it's a tower/desktop). If you've got a spare power supply, it might be worth swapping around to see if that affects anything. Beyond that, it may in fact be motherboard failure.

share|improve this answer
    
tried removing all RAM, removing video card, same response ... I notice the DVD light keeps blinking, and the HD Access light on the pc doesn't blink, it stays on ... does that give you any clue ? –  Run CMD Dec 19 '10 at 19:17
    
Have you rearranged any cables lately? I've seen some instances with a flipped IDE cable making lights stay on solid, with no boot. (Or was that a floppy drive cable? It's been a while!) –  Collin Allen Dec 19 '10 at 22:40

It sounds more like a hardware failure elsewhere, possibly the motherboard itself. One obvious thing to try is using the motherboard graphics output rather than a graphics card (assuming that you can!). This will tell you quite quickly if the problem lies in the graphics card or not.

Have you tried removing the memory, optical drive or even the hard drive to see if that affects the behaviour?

CMOS batteries are relatively cheap so you could just try replacing it and seeing what happens.

A more reliable solution would be to take to a local repair shop. They should be able to diagnose the problem quite quickly and shouldn't charge you for that (check first!) - as long as it doesn't take them more than a few minutes.

share|improve this answer
1  
at first I thought it was the Video card too, but replaced the card with another, and the same response ... unfortunately I can't connect the onboard VGA port since it's a male connector... –  Run CMD Dec 17 '10 at 23:29
1  
Try the CMOS battery. –  BBlake Dec 18 '10 at 16:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.