Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used the search feature in windows 7 and selected a folder from the results. Now if I want to move up the folder hierarchy I can't just use ALT+UP because to folder path is listed as:

search-ms:displayname=Start%20Menu%20Search%20Results%20in%20Files&crumb=System.StartMenu.Group%3A%3Dfiles&crumb=location:%3A%3A{DF95313-E44D-4AF-BE1B-CACEA2C3065}\Something

And I go back to the search results.

What's the best way to accomplish this task?

Thanks,

share|improve this question
up vote 1 down vote accepted

Select the item which folder you want to view, right click the item and select "Open Folder Location". You can then move up the directory tree as needed.

share|improve this answer
    
That option is not available to me when I right-click. – Almo May 26 '15 at 14:07

If you want to open a new window with "full path" instead of Search Results\"Path", but still have the search window remain intact, DO THIS:

After search results in Win 7, Right click on file and get option Open file location, then press Shift and then click on Open file location and a new window will open with the file highlighted and the search results window will also remain intact.

OR do the same but press control (ctrl) and click "Open" or "Open file Location", in the right-click menu, from the file!

share|improve this answer
    
I don't have these options in my context menu. – Almo May 26 '15 at 14:08

If your installation of Win 7 doesn't have open folder location or open file location, here's a solution:

http://www.sevenforums.com/tutorials/236988-open-file-location-add-remove-context-menu.html

Here's what's in that solution:

Windows Registry Editor Version 5.00

; Created by: Shawn Brink
; http://www.sevenforums.com
; Tutorial:  http://www.sevenforums.com/tutorials/236988-open-file-location-add-remove-context-menu.html

[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers\OpenContainingFolderMenu]
@="{37ea3a21-7493-4208-a011-7f9ea79ce9f5}"

[HKEY_CLASSES_ROOT\LibraryLocation\ShellEx\ContextMenuHandlers\OpenContainingFolderMenu]
@="{37ea3a21-7493-4208-a011-7f9ea79ce9f5}"

[HKEY_CLASSES_ROOT\Results\ShellEx\ContextMenuHandlers\OpenContainingFolderMenu]
@="{37ea3a21-7493-4208-a011-7f9ea79ce9f5}"

[HKEY_CLASSES_ROOT\.symlink\shellex\ContextMenuHandlers\OpenContainingFolderMenu]
@="{37ea3a21-7493-4208-a011-7f9ea79ce9f5}"
share|improve this answer

I found that:

  • Right click on the shortcut file name.
  • Then use the Open With... option.
  • Select the Windows Media Player option.
  • Press the cancel button (so it doesnt run).

It returns to the shortcut folder with that 1 item in the correct form (C:\Movies\... rather than search-ms:displayna...).

I have to do it for each shortcut item, which is kinda tedious, if I have a lot of them, but it works for me, for now). I have tried to select several at a time and it only works for 1 of the selection - maybe someone can figure it out for multiple items?

share|improve this answer
1  
Please try not to ask your questions in answers: superuser.com/help/deleted-answers – g2mk Dec 23 '15 at 22:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.