Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to control access to BitTorrent in my network. Presumably the best way to do this is using the router, a Netgear DG834GV.

I've set up a custom service that covers TCP ports 6881 - 6999 (port numbers from here). I've set up an Outbound Services filter that says "Block always".

alt text

Yet when I then start my test torrent (, the system is downloading the file regardless.

Is there some terribly obvious step that I might be missing here, that might account for the issue? Are there some other ranges that I should be blocking instead, maybe? Or maybe I just need to wait longer for the change to propagate before it will work?

share|improve this question

migrated from Dec 18 '10 at 14:24

This question came from our site for system and network administrators.

up vote 3 down vote accepted

BitTorrent can be very difficult to block completely, due to the different ports various clients can use. Attempting to block it based purely on the ports it uses is a bit futile, unfortunately. The page you've linked to is for the original BitTorrent client, and won't cover the multitude of BitTorrent clients that are out there now.

To be honest, the best way to block it, if it's absolutely essential, is to block all outbound access and just allow through the protocols you need. Other than that, without some kind of clever packet inspection, you're only going to get frustrated.

Sorry I couldn't offer any better advice!

share|improve this answer
Take a look at a 7-layer inspection/enforcement device, Packeteer, Palo Alto, but it's going to cost you. – SpacemanSpiff Dec 18 '10 at 13:51
+1 bittorrent can go via pretty much any port, only way to block it is to deny everything other than what you need or get a router that supports P2P filtering... but encryption can get round that. Hard one... – William Hilsum Dec 18 '10 at 14:29
Late to the party, disable UPNP in the router, this way the BT client cannot automatically configure port forwarding, then set a good password on the router. Not 100% but will make downloading with BT painfully slow if not useless. Be sure to delete any ports forwarded already. – Moab Mar 27 '11 at 16:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .