Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Windows 7, connecting to Samba shares

I can't get Windows 7 Home to connect to a Samba 2 share?

I keep seeing articles that suggest using 'secpol.msc', or 'gpedit' which I think isn't on the home version, as I cant find it.

I can connect on MacOS so I'm guessing the this is done to the Windows side of things.

The error I get is "A remote procedure call (RPC) protocol error occurred."

share|improve this question

marked as duplicate by studiohack, harrymc, random Dec 19 '10 at 1:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
What error are you getting? Please be more specific. –  user3463 Dec 18 '10 at 19:54
    
@studiohack yeah I read this one, win 7 home doesn't seem to have gpedit.msc as well –  PhilCK Dec 18 '10 at 20:36
    
that's correct. –  studiohack Dec 18 '10 at 20:39

1 Answer 1

up vote 0 down vote accepted

See this post (for what it's worth) by komickaze @ http://www.tomshardware.com/forum/75-63-windows-samba-issue:

I had a similar problem when trying to connect Windows 7 Home Premium and Windows 7 Ultimate to a Mac OS 10.3.9 Server. I made the following change with the Local Security Policy on Ultimate and tested it successfully while watching the registry for changes. I found the following REG_DWORD values were changed:

HKLM\System\CurrentControlSet\Control\Lsa\LmCompatibilityLevel HKLM\System\ControlSet001\Control\Lsa\LmCompatibilityLevel

After further testing, I found these to be the values and coresponding settings:

0) Send LM & NTLM responses
1) Send LM & NTLM - use NTLMv2 session security if negotiated
2) Send NTLM response only
3) Send NTLMv2 response only
4) Send NTLMv2 response only. Refuse LM
5) Send NTLMv2 response only. Refuse LM & NTLM

I created the LmCompatibilityLevel setting on my Home Premium machine with a value of 1 (http://www.builderau.com.au/blogs/codemonkeybusiness/viewblogpost.htm?p=339270746) and was finally able to connect to the 10.3.9 Server.

Located about halfway down the page, use CRTL+F and search for a keyword in komickaze's post.

share|improve this answer
    
Bingo, thanks for that. –  PhilCK Dec 18 '10 at 21:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.