Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A few days ago when I resume my computer from sleep mode in the mornings I would see an error dialog from "Windows Script Host" that read: "There is no script engine for file extension ".vbs". I am having hard time tracking down the source of this. I've looked through the event log, registry, and the scheduled tasks. But the lists are so long and I don't know where exactly to look for.

Details: It looks like it happens once a day and I only see it in the mornings. I'm on 64-bit Windows 7 Home Premium.

Any pointers are appreciated.

also, i think this started after one of those automatic windows updates.

share|improve this question

2 Answers 2

Not sure what is prompting to run a script, but here is a potential fix for the error.

http://www.nilpo.com/2009/07/windows-xp/error-there-is-no-script-engine-for-file-extension/

Step 1: Set a default script host Open a Command Prompt window. In Windows XP, click Start, Run…, and type cmd.exe. In Windows Vista and Windows 7, click Start and type cmd. Then select cmd in the Instant Search results. Type the following command and press Enter.

cscript.exe //H:WScript

Step 2: Registering the vbscript.dll module Open a Command Prompt window. In Windows XP, click Start, Run…, and type cmd.exe. In Windows Vista and Windows 7, run an elevated Command Prompt. Type the following command in the command prompt window and press Enter.

regsvr32 %systemroot%\system32\vbscript.dll

Step 3: Restore the .vbs file associations If the previous two solutions didn’t work, you should restore the file associations for the .vbs (VBScript) file type by downloading and running One of the registry files below.

http://www.nilpo.com/pub/scripts/FixVBSFileAssociationsXP.reg

http://www.nilpo.com/pub/scripts/FixVBSFileAssociationsVista.reg

.

share|improve this answer

You may want to look in your Scheduler to see what sort of stuff is trying to run every morning. Doesn't hurt to be paranoid.

The root cause of the problem is that you installed something (most likely an editor.. UltraEdit did this to me) that took over the .vbs extension. Open up Regedit, go to HKEY_CLASSES_ROOT.vbs and reset the default value to "VBSfile" (no quotation marks).

share|improve this answer
    
Wow. Thanks I think you're right I looked in regedit and saw that VBS has default value: bfvbsfile, which I found is for "BlueFish". That's a text editor I tried out a few weeks ago. –  PPC-Coder Dec 19 '10 at 20:09
1  
Great! Instead of manually hacking your way out of the mess, you may be able to use the editor's config pages to have it disassociate from certain file extensions. Make sure you use regedit to check if it actually worked. The reason I bring this up is because today it's .vbs that's broken for you... tomorrow it will be .js, etc. –  martona Dec 19 '10 at 21:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.