Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to install SmartSVN on Ubuntu. I have installed the latest sun-java6-jre package, but still I am getting such errors as

An incompatible Java version has been detected which has been reported to cause strange bugs. Aborting now.

Please install the latest release of the SUN Java SE Runtime Environment (JRE) from:

http://java.sun.com/javase/downloads/

or if it is already installed, make sure it is used.

How do I do it?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Maybe you also have another Java runtime installed and haven't set up the Sun JRE as the default. Run sudo update-alternatives --config java to change the default JRE, or give SmartSVN the full path to the Sun JRE (/usr/lib/jvm/java-6-sun/bin/java).

share|improve this answer
    
Thanks, I have changed the default JRE and it started working. –  ashish Dec 20 '10 at 5:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.