Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 32-bit.

I am unable to use any of the Autoplay features. I plug in a USB drive, pop in a CD, or connect a camera, and I get no reaction.

I need to restore the Autoplay function. How can I do this?

share|improve this question

5 Answers 5

Control Panel -> Programs -> Default Programs -> Change AutoPlay settings,

Adjust as required.

share|improve this answer
    
You can also get to this quickly from the start menu by typing 'autoplay' into the search box. –  Jimmy Dec 22 '10 at 1:56

From http://www.sevenforums.com/tutorials/27544-autoplay-enable-disable-autorun.html

Method 1:

1. Go to Control Panel\Hardware and Sound\AutoPlay.

To Enable:
At the top, check Use Autoplay for all devices and Click Save.

To Disable:
Uncheck Use Autoplay for all devices and Click Save.

Method 2:

1. Click Start and in the Search box, type gpedit.msc and press Enter.
Now browse to Computer Configuration\ Administrative Templates\ Windows Components\ Autoplay Policies\ Turn off Autoplay.

To Enable:
Change the value of Turn off Autoplay to disabled.


To Disable:
Change the value of Turn off Autoplay to enabled.
share|improve this answer
1  
No effect with either method. –  MAW74656 Dec 19 '10 at 23:40
    
Answers with just a link are generally frowned upon. It can result in an accepted answer just having a dead link. Copy and paste the info in or put it in your own words. I imagine that's why you're getting downvotes –  Joe Taylor Dec 20 '10 at 10:46
    
thanks for the heads up! –  Weltenwanderer Dec 20 '10 at 11:23
    
Thanks for the edit @Weltenwanderer! I'd suggest trying to give a little more background information or tutorial-like descriptions in your answers though. Your edit here is a great example of what a good answer should look like :-) –  Ivo Flipse Dec 20 '10 at 11:29

Maybe it can help you.....try-out this

On Microsoft site they have listed the following method

  1. Click Start, type Gpedit.msc in the Start Search box, and then press ENTER.
  2. If you are prompted for an administrator password or for confirmation, type the password, or click Allow.
  3. Under Computer Configuration, expand Administrative Templates, expand Windows Components, and then click Autoplay Policies.
  4. In the Details pane,see that the checkbox for Turn off Autoplay. is disabled

  5. In the Details pane, check the Default Behavior for AutoRun.

  6. Restart the computer.

share|improve this answer

Step One here:

  1. Ensure that AutoPlay is used for all media type and devices

Go to Control Panel -> Programs -> Default Programs, and select Change AutoPlay settings, or Control Panel -> Hardware and Sound -> AutoPlay.

AutoPlay Settings

Ensure that the check box for Use AutoPlay for all media and devices is ticked (enabled).

Enable and Turn On AutoPlay

Then, make sure that for the devices and media that you want AutoPlay dialog to prompt, Ask me every time is selected. If other option is selected, Windows will automatically performing the action without prompting for selection.

Alternatively, just click on Reset all defaults to reset and return AutoPlay settings to its original factory defaults.

Steps continued here:

http://www.mydigitallife.info/2010/08/11/fix-windows-7-autoplay-dialog-box-missing-or-not-appear-display-and-pop-up/

share|improve this answer
2  
Answers with just a link are generally frowned upon. It can result in an accepted answer just having a dead link. Copy and paste the info in or put it in your own words. I imagine that's why you're getting downvotes –  Joe Taylor Dec 20 '10 at 10:46

Copy and paste this to notepad and save as whateveryouwant.bat

This will only work if you run it as admin (the reason you need to run as admin is because this will edit the registry).

After you run this as admin, restart your computer and autorun should be enabled.

@echo off set key="HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer"

reg add %key% /v NoDriveTypeAutoRun /t REG_DWORD /d 145

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.