Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

UPDATE:
I've finally figured out a way to comprehensively fix this problem, though it took a lot of work and the creation of an Outlook 2010 addin! See below for the addin download. As far as I'm aware, though, there is no way to deal with this problem unless you install an addin to do it, because this is essentially caused by a bug in Microsoft Word's conversion of documents to HTML (which needs to happen before you send an Outlook HTML e-mail).

See down below for the original description of the problem (Outlook 2007, 2010, etc. not allowing proper inline responses because you can't break the blue "quote line" on the left).

My addin basically intercepts the e-mail before it is sent, grabs the Word document (if the e-mail format is to be HTML), and fixes the Word document's XML, before saving it as HTML and setting the e-mail's HTML body to the 'fixed' HTML. Then, finally, inline responding works. :-) It can be done by going to where you want to break the blue line, pressing Ctrl+Q, and entering the inline response. Without my addin installed, the blue quoteline will be reinstated in front of the inline response when you send the e-mail.

Here's a screenshot to show what inline responses look like in Outlook 2010 once the fix is applied (yeah, it's messy because I was comprehensively testing it; all the stuff here is exactly what the (top of the) e-mail looked like before I hit 'Send'):

enter image description here

THE ADDIN:
I have uploaded the source code of the addin that I had got round to developing when I originally posted this answer; I haven't had the time (or a copy of Outlook 2010 for that matter) to develop it further, so here's the disclaimer: this will probably not work at first because I can't remember where I was in developing it, but I know I got it to a proof of concept. I'm releasing this code under the GPLv3 so if someone with some development experience wants to try and get it working nicely with Outlook 2010, please do so and contribute your solution back (licensed under GPLv3) linked in a comment on this answer. However, I probably won't personally ever get round to making this a "finished" solution. The code is just to show you roughly how I did it. The addin is implemented in a Visual Studio 2010 solution, so you'll probably want to use that. Here's the download:
http://game-point.net/misc/OutlookQuoteFix.zip


ORIGINAL DESCRIPTION OF THE PROBLEM:
This has to be the most infuriating regression from Outlook 2003 to 2007. It also exists the same in Outlook 2010, as far as I can tell.

When you reply to an HTML e-mail message in Outlook, the quoted text has a blue line down the side, and is usually at the bottom of the message:

alt text

Now in Outlook 2003, when replying to HTML-formatted messages in Outlook, you used to be able to reply inline quite easily, by getting to the point in the quoted message you wanted to reply to, and pressing the 'decrease indent' button:

alt text

Since Outlook 2007 (and 2010), they replaced the e-mail editor with Microsoft Word. This means the blue line is implemented in a different way; it uses a blue left border. This makes it tougher to break the line up. After much ado, I found a couple of pages that said that you could remove all formatting by pressing Ctrl+Q, which would remove the blue line next to the cursor and allow inline replies:

alt text

OK, not too bad on the face of it. I can live with that. But here's the kick in the teeth; try sending that mail. I'll send it to myself. What do I receive? This:

alt text

Outlook 2010 reinstated the blue line, where I had removed it, upon my sending the e-mail! For God's sake! The two pages I linked to above don't seem to address Outlook's reinstating of the blue line upon sending.

So, does anyone know how you can actually reply inline in Outlook 2010 (or Outlook 2007) e-mail without the blue line being reinstated? Before anyone says, I do not want to convert the message to plaintext, and I do not want to just indent replies and have to manually build the blue line myself. I want something like the Outlook 2003 behaviour; I reply, Outlook creates the blue line, and I can break it up with inline replies, send it, and my inline formatting stays.

share|improve this question
10  
+1 because at least I now know I'm not going crazy. It's just Outlook. –  atomicules May 27 '11 at 9:44
    
Is the difference in text colour not enough to differentiate between the original email and your additions? –  Connor W May 30 '11 at 20:22
2  
Not really, and that doesn't work for multiple levels of indentation, and having a blue line next to the responses is misleading because to me it implies indentation. –  Jez May 30 '11 at 21:06
2  
I have found a “solution”: When replying to HTML-formatted mails, I switch the “when replying…” switch from “insert >” to indent, which is the only usable option for inline replies, I guess. (And yes, this means switching the option between HTML and plain-text replies. Microsoft Outlook…) –  Mormegil Oct 25 '11 at 9:44
17  
So where's the addin? PLEASE! –  stolsvik Nov 15 '11 at 8:27

3 Answers 3

Interesting - I don't recall ever seeing the blue border. I do not have this configured in my Outlook 2007. Is there a setting for it somewhere? I couldn't find it. Perhaps it's part of your stationary?

I find most of the time replying to emails above previous messages to be acceptable. I think the only time inline replies are relevant are when you answer multiple questions. In this case I understand wanting to make them stand out (with no border).

How about changing your standard to this: disable the blue bar entirely. I think this is a pretty rare feature to use these days.. When you do inline replies, just choose a different, bright colour for your font. This is pretty easy to do now with the contextual tooltip when you select text. This might be a tiny bit more work, but with my theory, you wouldn't really be doing it that often.

share|improve this answer
5  
That's what people often do because they're blissfully unaware of quoting via indentation, and I think it looks terrible. It's also not scalable; it might work for one reply, but if you've got a conversation going between multiple people, you'll quickly forget whose text is which color and which 'level' of quote you're on. –  Jez Jan 16 '11 at 10:31
    
There's a setting under stationery and fonts to automatically change the font color. –  Mark Sowul Mar 2 '11 at 1:04

I found a solution that seems to work (I'm using Outlook 2007). Say you got an email and you hit reply. Looking at your reply email with that blue indent line click on the "options" pull down menu and then change the format to "Rich Text". Enter your reply in the body of the email and select your reply line or paragraph and then ctrl-Q. The blue line for that paragraph or email is gone. I tested this by sending the email back to myself and it seems to work.

If the format is HTML it won't work... although ctrl-Q seems to remove the blue indent line when I send the email back to myself the line comes back. But in Rich Text format the solution sticks...

share|improve this answer
1  
Note to self: "CTRL+Q is Remove paragraph formatting." I've no idea where the actual menu command for this is though. –  atomicules May 27 '11 at 9:52
    
Also, converting to Rich Text works in Outlook 2010 as well. Thanks @Peaceplease –  atomicules May 27 '11 at 9:56
1  
You can also use CTRL+Space to use your default style. Combined with CTRL+Q you can do it all with the keyboard. (Assuming your default style doesn't match that of the message you are replying to). –  RobM Aug 10 '11 at 10:54
    
THIS. I just noticed it, and indeed, converting to Rich Text does cause the blue line removal to stick. :-) I wonder whether Outlook 2003 used rich text in its e-mails then? –  Jez Sep 21 '11 at 16:35

Not quite solution, but I've just found out in Outlook 2010 that although the Ctrl+Q trick (to remove the blue line indentation for inline replies) does not work for the emails indented by blue line (option "Prefix each line of the original message"), it does work OK for emails just indented (option "Include and indent original message") even after the email is sent and received.

After searching, I found this being mentioned also for example here: http://www.msoutlook.info/question/400

Changing the message format to RTF (instead of HTML), which reportedly works, is obviously not a solution - I really do not want to send unreadable-at-all email with "winmail.dat" attachment to all those people that are not using Microsoft Outlook.

share|improve this answer

protected by studiohack May 30 '11 at 19:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.