Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this as a gnus configuration:

(setq imap-shell-program "/usr/local/sbin/dovecot -c /Users/hinmanm/.dovecotrc --exec-mail imap")
(setq gnus-select-method '(nnimap "Mail"
                                  (nnimap-stream shell)))

This works fine from terminal Emacs, however in Cocoa emacs, the dovecot server is not started and Gnus says the mailbox is denied.

I faintly recall someone telling me there was a difference between the way terminal emacs and cocoa emacs spawned processes. How can I get this to work in Cocoa emacs?

share|improve this question
    
just to confirm: You're using Cocoa Emacs and not Aquamacs, right? –  pope Feb 26 '11 at 22:33
add comment

1 Answer

I have this working on my machine, but my configuration is every so slightly different.

(setq gnus-select-method '(nnnil "")
      gnus-secondary-select-methods
      '(
        (nnimap "mail"
                (nnimap-address "localhost")
                (nnimap-stream shell)
                (imap-shell-program "/opt/local/libexec/dovecot/imap -c ~/.dovecotrc")))

The differences being that I have the imap-shell-program setting in with my nnimap settings (as well as that it's apart of my secondary select methods and that I'm using a different version of dovecot, but I think those are interchangable)

share|improve this answer
    
I did notice that I run the latest gnus, I need to move the imap-shell-program variable outside of nnimap. –  pope Feb 26 '11 at 22:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.