Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using a DIR-655 router and I have two servers on the local network. I'd like to be able to SSH into both and use one as a web server.

If I use port forwarding to forward both ports 22 and 80 to the server I want to use as a web server it works.

However when I try to use the Virtual Server it fails. Even if I just want to use the virtual server instead of port forwarding for just the web server.

Ideally what I'm trying to do is use Virtual Server to

  • forward port XXX01 to port 22 (SSH) on server 1,
  • forward port XXX02 to port 22 (SSH) on server 2, and
  • forward port 80 to port 80 on server 2.

I think, though I may be hallucinating after struggling with this frustratingly for a while, that at one point it was sort of working if I used port forwarding just for SSH on server 1 and the used the Virtual Server features for the rest, but I can't be positive...

Any ideas? It has to be something really basic I'm missing? At least I hope so!

Thanks!!

(Also one other strange thing is that I can't ping the router from outside of the network using just the Virtual Server...)

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

It's solved. The ports are blocked by another firewall (everything except 22 and 80!) so it's not a problem with the router configuration. My bad :).

share|improve this answer
    
If this solved your question, you should mark it as an answer, even when it's asked by you and answered by you. –  Olli Feb 7 '11 at 11:42
add comment

I had the same problem - this weekend I found the solution.

I changed the static IP address on my server to dynamic and then reserved this address in the DHCP server list on my router.

After this, port forwarding worked fine and my server was accessible again via HTTP (port 80) and FTP (port 21).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.