Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Can someone advise me as to how to get FTP working in emacs? It doesn't have to be SFTP, etc, just plain old FTP. I've tried multiple times, and never could get it working. I think the closest I got one time was having an FTP prompt in emacs, but It wouldn't list any dirs. The only think tying me to an IDE is the remote directory tree on the left. If I could just somehow list, get, edit, and put (preferably as soon as I hit save, automagically) files /inside/ of emacs, without having to use Filezilla / FireFTP / etc, then I'd be super happy!

tl;dr; Enable FTP browsing, etc, in emacs?

share|improve this question
up vote 3 down vote accepted

Ange-ftp will do ftp/sftp for you... look here:

(Use Tramp too, which wraps Ange-ftp)

share|improve this answer
I've messed with that, but it is completely confusing. Plus it looks like I have to know the exact file name / location for that. I was hoping there'd be a way to browse a server. – Josh Dec 20 '10 at 21:48
I really'd like to find something that works just like Dired (C-x d), and lets me browse that way. – Josh Dec 20 '10 at 21:50
@Josh, are you after dired style browsing of FTP/SFTP? – Slomojo Dec 20 '10 at 21:52
.... I see that you are :) I hear that ange-ftp + tramp will give you dired mode, although I don't use it so I can't confirm. – Slomojo Dec 20 '10 at 21:53
What problems are you having with ange-ftp ? – Slomojo Dec 20 '10 at 21:59

I think you're looking for something like TRAMP.

It allows you transparent access to files on remote
access. “Transparent” means that usually the user doesn’t have to
worry about anything. All that changes is the filename convention
to indicate that the file resides on a remote system.
share|improve this answer
Tramp hands over it's FTP access to Ange-ftp (which in turn hands it over to an external console style ftp client (e.g. gnu ftp)) – Slomojo Dec 20 '10 at 22:01
I try: C-x C-f; / , and it says: "Process tramp/scp josh exited abnormally with code 255" & (at bottom) "File error: process died" – Josh Dec 20 '10 at 22:02
that address style will have Tramp attempt an ssh/scp transfer, you need to use the protocol header ftp:// - if your host is SFTP it should work with tramp (without ange) if it's just FTP, you need ange installed (and configured!) too. – Slomojo Dec 20 '10 at 22:04
What exactly should I type in? I type C-x C-f, then ftp: // (no space on the ftp protocol, the formatter is being weird on the page), and it wraps it like: Find file: {ftp:/} /, then dies with the same error. – Josh Dec 20 '10 at 22:07
C-x C-f ... minibuffer -> Find File: should go to the root folder if ange-ftp is configured right. (did you setup the ftp client for ange?) – Slomojo Dec 20 '10 at 22:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .