Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there a commandline flag for IE-8 to launch it from the commandline directly into full screen mode?

share|improve this question
up vote 2 down vote accepted

-k will start Internet Explorer mode in Full Screen mode.

iexplore -k
share|improve this answer

For anyone else's information, this actually opens Internet Explorer into "Kiosk" mode, with no way to exit other than hitting Alt + F4.

Full screen mode is different and has no argument from CMD, however, can be configured in Group Policy as follows:

Type regedit in RUN dialog box and press Enter. It'll open Registry Editor.

  1. Now go to following key:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\

  2. Create a new key Internet Explorer under Microsoft and then create another new key Main under Internet Explorer key. The final key structure would be:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\Main

  3. In right-side pane, create a new DWORD AlwaysShowMenus and set its value to 0

PS: Remember we have covered the same Registry key long time back here?

  1. Again go to following key:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer

  2. Create a new key Toolbars under Internet Explorer key and then create another new key Restrictions under Toolbars key. The final key structure would be:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\Toolbars\Restrictions

  3. In right-side pane, create 2 new DWORDs NoNavBar and NoCommandBar and set their values to 1

That's it. Close Registry Editor and restart Internet Explorer. Now IE will always open in full screen mode.

If you want to turn full screen mode off in future, delete all 3 DWORDs created in above steps.

share|improve this answer
    
@Jherran, you downvoted because my numbering wasn't accurate? C'mon... that's the solution and you barely edited anything.. – sag May 8 '15 at 14:42
    
Sorry man, but I didn't downvote you. Just edited. Don't use win, don't know if works, so not me the person you are looking for. – jherran May 8 '15 at 14:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.