Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

UPDATE:

I bought a new CDROM drive, as recommended by HP. It still doesn't work. I can open and close it now; so that's changed. But it still doesn't appear as a drive, and I can't use it. Any other ideas? Thanks.

--

Here's as best as I can describe it:

When starting up, the boot order doesn't recognize the cdrom drive, but I can open and close the drive during this time.

In Windows 7, I can't open the cdrom drive, and it doesn't recognize it in device manager, disk management, or my computer.

In Ubuntu Linux, I can open the cdrom drive, but it still doesn't recognize the cds, and it won't mount.

If I reformat everything, would my cdrom drive work again? Can I reinstall Windows without a cdrom drive? I've deleted the upper and lower filters as was suggested in Google searches. Took the disk drive out and checked that it was installed correctly (no reason it shouldn't have been). Still: nothing works.

share|improve this question
    
So BIOS doesn't see the CD-ROM drive? When you tried to boot from the external CD-ROM drive, did BIOS recognize that device? Have you tried upgrading your BIOS? –  goblinbox Dec 21 '10 at 6:56
    
I flashed the bios, yes. –  bozdoz Mar 1 '11 at 14:43

2 Answers 2

It is most almost entirely sure a hardward problem a physical problem, your cd drive needs a repair or you need a new one. If you didnt mess with the BIOS settings before the problem started, is almost sure that there is something broken with the physical unit, and no a reinstall won't help.

You might want to try to unplug it and plug it in again, and blowing some air with a vaccum cleaner or a can of compressed air, or an air compressor if you happen to have one, but most probably you will need to get a new one, since repairs are usually not worth the money.

If you don't move your laptop that much or you don't want to open your laptop get a usb drive, they are pretty cheap these days.

share|improve this answer
    
I tried booting with an external cdrom drive, too. That didn't work. I can only boot from USB and harddrive. –  bozdoz Dec 21 '10 at 5:43
    
Hardware problem, time to get a new drive. –  Guillermo Siliceo Trueba Dec 22 '10 at 1:51
    
Didn't work. Got a new drive; same problems, except now I can open and shut the cd rom drive. –  bozdoz Mar 1 '11 at 15:47

If neither Windows nor Ubuntu are letting you mount discs, then that points to a hardware issue. I doubt reformatting and reinstalling would work. Chances are that the cdrom drive does not show in Device Manager, then the connection is not secure. Since you've already removed and re-installed it, that would suggest an issue with the drive itself.

I would double-check to make sure it's not listed in the Device Manager. If it isn't there, then you may need to buy a new drive. Before you do that though, take out the drive, and take a picture of the connector and post it here so someone can determine if it's a standard connector or proprietary. Then someone can tell you what to look for.

share|improve this answer
    
I tried booting with an external cdrom drive, too. That didn't work. I can only boot from USB and harddrive. –  bozdoz Dec 21 '10 at 5:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.