Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some time now I've had a problem when copying and pasting between Outlook 2007 windows, or from other office apps into Outlook 2007. When I paste, say into a new email, the email window's text area goes blank. The window isn't 'not responding', the To and Subject contents are still visible, but it looks like all the text in the email has been deleted. Initially I thought it was just taking ages to paste, but it turns out I need to switch focus to another window and then switch focus back to the Outlook window. Only then does the body of the email repaint itself. It's at the point that I click onto the Outlook window that the body area changes from blank white to showing all the text that was there before plus the pasted text.

This problem is completely reproduceable. So now instead of CTRL-V to paste, I usually have to press CTRL-V, ALT-TAB, ALT-TAB, to paste and switch windows.

I think it's related to the format/style of the source and destination text. If I'm just copying text without formatting then it pastes normally. If I copy, for example, two lines from a numbered list then the repainting problem occurs. But then if I re-paste the lines again into the section I've just pasted then the problem doesn't occur. But if re-pasting the lines again into a different section in the destination document the problem does occur.

Any ideas? I've updated my graphics driver. Not sure what else it could be.

I do sometimes have similar problems in Visual Studio 2010 too: when I paste text into a code window it doesn't show immediately, but the rest of the window shows what was there before I pasted.

I'm using Win XP with all updates applid, on a Dell Vostro 1510.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Describing the problem made me think it might be related to the Outlook/office Paste options (Tools > Options > Mail Format > Editor Options.. > Advanced > Cut, Copy & Paste) I had them all set to Match Destination Formatting. Now I've changed them to the Defaults ('Keep Source Formatting' for all except Pasting between emails when style definitions conflict: Use Destination Styles) and the problem appears to have gone away!

If I then change the options back to Match Destination Formatting the problem reappears.

Awesome, I'm glad there's a solution. But anyone know why this problem happens at all, or how to get it to work with Match Destination Formatting options?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.