Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Firefox 3.5 on OSX.

When I try to go to a website that doesn't exist (because I forget to start my VPN), it brings me to the Virgilio search page.

http://auto.ricerca.alice.it/where.i.really.want.to.go.com

After that happens, I get to that page even once I start my VPN, unless I restart Firefox. Is there any way to avoid this?

share|improve this question
up vote 3 down vote accepted

if that url is from your ISP trying to provide a fancy "domain not found" page to you, you should either disable that feature (I know at least it is possible with T-Online), or you should reduce the value of Network.dnsCacheExpiration on the about:config page.

share|improve this answer
    
Great. I will check if I can disable it, which would be on my router? Dealing with this ISP is best avoided :) – Dan Rosenstark Aug 13 '09 at 21:10
    
usually it is where you change your password or your billing address, or your bandwidth plan, i. e. on the website of your ISP. – mihi Aug 14 '09 at 16:07
    
OH god, you do not want to deal with the website of an italian ISP. – Dan Rosenstark Aug 15 '09 at 1:39
    
if you prefer, and the costs are not astonomically high (as it is with German ISPs) you can call its hotline instead ;) – mihi Aug 15 '09 at 9:49
    
good point, that would be free since they provide my phone. Except that I'd need to buy a physical phone :) – Dan Rosenstark Aug 21 '09 at 20:08

Look in about:config for keyword.url. It should match that Italian website. Turn off keyword.enabled. Good luck!

share|improve this answer
    
Nope, that goes to google. – Dan Rosenstark Aug 13 '09 at 19:47

It's probably caching that site. Have you tried Ctrl-Shift-R to reload the page without the cache?

share|improve this answer
    
I'm not sure if that solves it. I'll report back after some testing. Thank you. – Dan Rosenstark Aug 13 '09 at 21:11
    
Nope that's not it, even persists if I try to start from the URL fresh. Thanks though. – Dan Rosenstark Aug 15 '09 at 1:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .