Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Problem

Retrospect is a backup system that my organization uses, but I can not find support for my Ubuntu 12.10 64bit desktop.

What I have tried (but did not work)

  1. download the Redhat version and attempt to convert to deb

    wget http://download.dantz.com/archives/Linux_Client-7_6_100.rpm
    sudo alien Linux_Client-7_6_100.rpm
    
  2. The Restrospect user forum has this thread, which provides an i386 .deb file for installing Retrospect

Question

Is there a way to install this on my system?

share|improve this question

1 Answer 1

The i386 Debian package file should be able to be "forcefully" installed on an amd64 system via

dpkg -i --force-architecture

This will probably leave other issues lingering before the application can be used; the package probably depends on other libraries, specifically the i386 versions of these.

This is addressed in Debian, and therefore Ubuntu, by the multiarch project. This enables a system to have the same libraries compiled for different architectures installed simultaneously. However, perhaps the package you are referring to does not have any problematic external package dependencies, and then you won't need these multiarch libraries (the forum post linked below kind of suggests this is the case).

How to continue from this point depends on the packages internal dependencies and layout. This Ubuntu forum post seems to handle the exact situation of installing Retrospect on 64-bit Ubuntu, opting for

  1. alien conversion from RPM to Debian package format
  2. manually changing the i386 string to amd64 in the debian/control file
  3. rebuilding the package.

I propose that step 2 should not be needed with the --force-architecture switch to dpkg, but if you do some experimenting, you will probably see how it works in practice.

Note that the forum post lists the packages libstdc++6 and libc6-i386 as prerequisites for Retrospect (this is where multiarch might be needed, but the person in the forum post seems to have managed without).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.